The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Closed Thread
 
Thread Tools Search this Thread Rating: Thread Rating: 72 votes, 5.00 average. Display Modes
  #61  
Old 11-03-2014, 10:10 PM
Rvh's Avatar
Rvh Rvh is offline
CORSAIR Beta Team
Rvh's PC Specs
 
Join Date: Nov 2014
Location: Europe, The Netherlands
Posts: 982
POST ID # = 739810
Rvh Reputation: 39
Default

I had my k70 rgb keyboard in use for 2 months, had never bothered to update it's drivers as i was happy with the state it was in (working perfectly lol) no malfunctions, freezing leds whilst opening steam or booting games, keyboard would properly shutdown with profiles saved to device memory, decided to download the latest, all kinds of issues appear, decided to re install multiple times to no avail, so my last resort was submitting a ticket which quite frank didn't help either (i asked for the "Corsair Gaming Software" of last september since it worked flawlessly). The response to my ticket basically told me that the latest driver was the most stable one ironically :/

So quick sum up of current problems
-booting steam may or may not freeze LEDS
-booting games in steam may or may not freeze LED's
-booting my pc up gives a bios error "0 keyboard detected" (asus mobo)
-keyboard randomly no device found

My keyboard was running for at least 6 hours a day on average playing animations on the LED's never was there any problem, nor any problems with steam.
I really don't know what to do with it anymore.


  #62  
Old 11-04-2014, 10:25 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,463
POST ID # = 740031
Corsair James Reputation: 75
Default

Quote:
Originally Posted by Rvh View Post
I had my k70 rgb keyboard in use for 2 months, had never bothered to update it's drivers as i was happy with the state it was in (working perfectly lol) no malfunctions, freezing leds whilst opening steam or booting games, keyboard would properly shutdown with profiles saved to device memory, decided to download the latest, all kinds of issues appear, decided to re install multiple times to no avail, so my last resort was submitting a ticket which quite frank didn't help either (i asked for the "Corsair Gaming Software" of last september since it worked flawlessly). The response to my ticket basically told me that the latest driver was the most stable one ironically :/

So quick sum up of current problems
-booting steam may or may not freeze LEDS
-booting games in steam may or may not freeze LED's
-booting my pc up gives a bios error "0 keyboard detected" (asus mobo)
-keyboard randomly no device found

My keyboard was running for at least 6 hours a day on average playing animations on the LED's never was there any problem, nor any problems with steam.
I really don't know what to do with it anymore.
We hear you and understand the frustration. We're doing everything we can to address these issues. We have improved our QA procedures and are putting in as many resources as possible to push out updates on a timely basis. Some issues are taking longer to investigate due to difficulty in reproducing them but we are doing what we can to ensure the experience remains a positive one.


  #63  
Old 11-04-2014, 11:13 PM
Rvh's Avatar
Rvh Rvh is offline
CORSAIR Beta Team
Rvh's PC Specs
 
Join Date: Nov 2014
Location: Europe, The Netherlands
Posts: 982
POST ID # = 740042
Rvh Reputation: 39
Default

Quote:
Originally Posted by Corsair James View Post
We hear you and understand the frustration. We're doing everything we can to address these issues. We have improved our QA procedures and are putting in as many resources as possible to push out updates on a timely basis. Some issues are taking longer to investigate due to difficulty in reproducing them but we are doing what we can to ensure the experience remains a positive one.
Thanks alot for responding! I wonder though why there is no way to rollback to the older driver/firmware that worked flawlessly for me, it would pretty much remedy the headache it's causing right now. I just hope the issues get sorted soon as i really don't wanna go back to a logitech k120 as i really do like the product :).


  #64  
Old 11-05-2014, 06:22 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,463
POST ID # = 740232
Corsair James Reputation: 75
Default

Quote:
Originally Posted by Rvh View Post
Thanks alot for responding! I wonder though why there is no way to rollback to the older driver/firmware that worked flawlessly for me, it would pretty much remedy the headache it's causing right now. I just hope the issues get sorted soon as i really don't wanna go back to a logitech k120 as i really do like the product :).
We never see a reason to rollback since the software only fixes and improves - it doesn't add anything "new" persay.

If you had a version that worked before and not now, we should address it and see why that is.


  #65  
Old 11-05-2014, 11:12 PM
Rvh's Avatar
Rvh Rvh is offline
CORSAIR Beta Team
Rvh's PC Specs
 
Join Date: Nov 2014
Location: Europe, The Netherlands
Posts: 982
POST ID # = 740271
Rvh Reputation: 39
Default

Hmm, all i can do is hope it will be adressed and fixed then! Is there anything i can provide? Sadly i can't recall what version of the software i had installed previously (imagening that would actually be pretty helpful info) it was however one of the older ones with the sail logo.

It turned from a smooth ride into a nightmare!


  #66  
Old 11-07-2014, 03:11 PM
stevvie stevvie is offline
Registered User
stevvie's PC Specs
 
Join Date: Dec 2007
Posts: 191
POST ID # = 740579
stevvie Reputation: 10
Default

I'm running the latest beta of steam (only when i have too, its a dreadful organization) and have never had cue stop, and i run a few times a day, due to gauntlet and Euro Truck Simulator.


  #67  
Old 11-08-2014, 05:24 PM
randomhat randomhat is offline
Registered User
randomhat's PC Specs
 
Join Date: Nov 2014
Posts: 15
POST ID # = 740763
randomhat Reputation: 10
Default

when is update 1.14 coming out
im still having problems with steam
i tried this yesterday http://forum.corsair.com/v3/showthread.php?t=133370
and it worked for the day,today i turn my computer on and start steam and
lighting freezes on keyboard cant change profiles
how long before it comes out please ?


  #68  
Old 11-09-2014, 12:10 AM
Rvh's Avatar
Rvh Rvh is offline
CORSAIR Beta Team
Rvh's PC Specs
 
Join Date: Nov 2014
Location: Europe, The Netherlands
Posts: 982
POST ID # = 740804
Rvh Reputation: 39
Default

Well, i solved my steam issue by using the two 2.o ports instead of one 3.o, only issues left is the board not shutting off as it used to on shutdown, temporarily saved a blank profile to the device memory to remedy that.

The main problem i got left is as follow: on startup CUE claims it's displaying my default profile, although it's still displaying what's on it's Device Memory. Exiting CUE and restarting will make it switch to default profile. If anyone has ideas please post them!


  #69  
Old 11-09-2014, 06:09 AM
quake3trust quake3trust is offline
Registered User
 
Join Date: Sep 2014
Posts: 14
POST ID # = 740835
quake3trust Reputation: 20
Default

Hey I found this on my local appdata, not sure if it can help you guys but im having issues with the keyboard with multiple programs such as steam, mumble maybe others i dont know...
Attached Files
File Type: txt 4.txt (30.3 KB, 191 views)


  #70  
Old 11-09-2014, 11:55 AM
Rvh's Avatar
Rvh Rvh is offline
CORSAIR Beta Team
Rvh's PC Specs
 
Join Date: Nov 2014
Location: Europe, The Netherlands
Posts: 982
POST ID # = 740880
Rvh Reputation: 39
Default

Quote:
Originally Posted by Rvh View Post
Well, i solved my steam issue by using the two 2.o ports instead of one 3.o, only issues left is the board not shutting off as it used to on shutdown, temporarily saved a blank profile to the device memory to remedy that.

The main problem i got left is as follow: on startup CUE claims it's displaying my default profile, although it's still displaying what's on it's Device Memory. Exiting CUE and restarting will make it switch to default profile. If anyone has ideas please post them!
Re-Installing CUE to my 2TB HD instead of my SSD seemed to have fixed the issue of CUE not switching to the default profile on Startup. maybe this issue was caused by CUE booting faster than the keyboard itself? so basically the only issue i got left now is the lights not turning of anymore! but i got a temporary fix for that as of now.


  #71  
Old 11-09-2014, 07:16 PM
CanadianGuy1975 CanadianGuy1975 is offline
Registered User
CanadianGuy1975's PC Specs
 
Join Date: Oct 2014
Posts: 9
POST ID # = 740963
CanadianGuy1975 Reputation: 11
Default

I do have the problem where CUE V1.2.7looses communication with the keyboard when using a Steam game. This weekend I did a complete new windows 7 x64 install. All updates, latest drivers for MB and video cards, etc... the problem is present. I do not use CUE to switch the profiles automatically, I use a key but that was also not working. To resolve I must quit CUE and restart.

Should you require more please let me know.
-------
One thing to note when CUE looses communication with the keyboard the keyboard still functions except for the led effects but what is interesting is the dim level button does not have any affect on the brightness. Even if the pc gets turn off.

Last edited by CanadianGuy1975; 11-11-2014 at 10:03 PM.


  #72  
Old 11-14-2014, 07:57 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,463
POST ID # = 741837
Corsair James Reputation: 75
Default

Hi all, just for your reference, we have released a new firmware that should resolve the Steam issue.

In some cases we have found that if you're using a third party USB 3.0 controller like the Asmedia 1042 chipset, you'll need to update your drivers and/or the BIOS to resolve the issue as its related to the hardware.

Here is the thread to the patch notes: http://forum.corsair.com/v3/showthread.php?t=134450

If you still continue to have problems after updating FW, updating USB drivers, and updating the BIOS, please post here so I can continue to track it.

Last edited by Corsair James; 11-14-2014 at 08:01 PM.


  #73  
Old 11-16-2014, 11:21 AM
deft88 deft88 is offline
Registered User
 
Join Date: Nov 2014
Posts: 1
POST ID # = 742149
deft88 Reputation: 10
Default

Hi James, I have updated my K95 firmware, my USB drivers are the latest and I am using the latest version of CUE as well. But I am still encountering this problem.
Attached Files
File Type: txt tmp.txt (111.9 KB, 117 views)

Last edited by deft88; 11-16-2014 at 11:29 AM. Reason: Updated post with CUE log


  #74  
Old 11-16-2014, 06:40 PM
DGmustard DGmustard is offline
Registered User
DGmustard's PC Specs
 
Join Date: Oct 2014
Posts: 7
POST ID # = 742205
DGmustard Reputation: 10
Default

Re-installed CUE and updated RGB K70 firmware to 1.15

Steam still lags on opening (freezing keyboard animations until restart).

Kodi/XBMC also stops responding at initial loading screen.
Attached Files
File Type: zip logs.zip (8.0 KB, 110 views)


  #75  
Old 11-16-2014, 07:19 PM
CanadianGuy1975 CanadianGuy1975 is offline
Registered User
CanadianGuy1975's PC Specs
 
Join Date: Oct 2014
Posts: 9
POST ID # = 742211
CanadianGuy1975 Reputation: 11
Default

Well at first it seemed to resolve the problem but after an extended run in Grid 2 the CUE software lost communication with the keyboard. Again the keyboard would still operate (keys understood) but the lighting affect is lost. I first tried to simply restart the software but I had to reboot(unplug and replug) the keyboard.

Last edited by CanadianGuy1975; 11-16-2014 at 09:16 PM.


Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.