The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #16  
Old 09-23-2018, 06:44 AM
ifnt05 ifnt05 is offline
Registered User
 
Join Date: Sep 2018
Posts: 1
POST ID # = 973846
ifnt05 Reputation: 10
Default

Have you guys tried charging it from the wall? Like using a phone charger or something like that?

If i plug it into my PC's USB 3.0 port it will charge to 80-85%, if i plug it into the wall with my phones fast-charger it goes up to 100%.

I guess the USB port on the PC isn't capable of charging it, or it just takes way too much time after the 80% mark.
Reply With Quote


  #17  
Old 10-02-2018, 02:19 PM
mrgrimms mrgrimms is offline
Registered User
mrgrimms's PC Specs
 
Join Date: Aug 2018
Location: California
Posts: 4
POST ID # = 974998
mrgrimms Reputation: 10
Default

I've actually been having the same issue. I use it for about 4-5 hours a night and then have to leave it on while I charge it over night. When I come back the next day it says its about 85-92% but wont charge over that, even playing and leaving it plugged in. I will try the charging with the wall tonight and see how that works.
Reply With Quote


  #18  
Old 10-04-2018, 10:21 AM
DustDevilNM DustDevilNM is offline
Registered User
 
Join Date: Nov 2010
Posts: 2
POST ID # = 975146
DustDevilNM Reputation: 10
Default

Same issues as everyone above. I have the latest iCue (3.7.99) all firmware on all my Corsair products are up to date. I let my HS70 charge off the front usb (2.0/3.0) panel 12-16 hours a night and come back and play a game for 15-20 minutes only to have the notification say "battery low" I checked the iCue status of the charging and it never goes above 90% I also have a linked or separate issue with PUBG. I haven't had problems until recently but wirelessly or connected to usb (2.0/3.0) front panel the games audio goes in and out 3-5 seconds and picks back up. I just thought had a bad headset but looking over the forums others have has the same issue.

I have submitted a ticket and will proceed from there.
Reply With Quote


  #19  
Old 10-05-2018, 02:02 PM
khaos khaos is offline
Registered User
 
Join Date: Sep 2008
Posts: 17
POST ID # = 975283
khaos Reputation: 10
Default

I've also had charging issues with my HS70. It's always a guessing game what percentage the battery will be at after I unplug it. Sometimes it will be at 100%, but commonly it will be some seemingly random percentage below that. Sometimes it is 92% or 96% or 72% or anything else.

For a very short time I thought I had figured it out. Originally I was turning the headset off and then plugging it in to charge. I decided to leave the headset on (while also leaving my computer on even though the USB ports do still provide power when the computer is off) so I could hear the "Battery Charging" and "Battery Complete" voice prompts.

Twice in a row this method resulted in the iCUE showing 100% charge after unplugging. I thought this had solved it. Maybe the headset somehow better regulates charging when it is left on or maybe leaving my computer on meant the iCUE software could work some magic. However, earlier today I unplugged it (light was green, had been charging for hours) and it only showed 96%. Not that far off from 100, but I decided to plug it back in.

Unplugged it a few hours later and the batter had gone DOWN to 88%. It started at 96%, I plugged it in, the light turned orange and then AFTER the light was green the battery had actually dropped to 88%. While plugged in.

I also have tried plugging the headset into my Anker 5-port USB charger (that I use for my phone and smart watch) with equally mixed success.

Honestly not really sure what to do at this point. I can still return it to the store I bought it from so I'm not convinced it is worth pursuing warranty work through Corsair. Also not sure if it is worth swapping it out for another one since other people are having this problem.

Real pity because I love the HS70 in every other way.

Last edited by khaos; 10-05-2018 at 02:04 PM.
Reply With Quote


  #20  
Old 10-09-2018, 11:29 PM
Ptl775 Ptl775 is offline
Registered User
 
Join Date: Jun 2018
Posts: 2
POST ID # = 975820
Ptl775 Reputation: 10
Default Update... but no solution

I posted originally about the charging issue I had with my HS 70SE (purchased at Best Buy).

I don't think i ever had 100% battery reading. All software through Corsair has been updated as well. I would get about 80% or 88% after charging for 12 plus hours or even greater. When I unplugged the charging cable it would show as green meaning that it was "fully" charged. The unit was plugged into my USB power hub which plugs directly to wall. USB hub is for charging only.

I returned the headset back to Best Buy and exchanged for another headset which is was the same HS 70SE. Again i was having the same issues.

I returned again and decided to go with another brand. It was wireless, more expensive, worked better, but it didn't fit right.

Amazon had a huge sale on the HS 70 (carbon edition) so being the frugal person I am, i returned the expensive set and repurchased the HS 70 hoping that maybe it was a "SE" issue. Well it wasn't and I still have the same issue with my current HS 70.

As I am writing this review I had the headphones charged over night (16 hours) and a green light before unplugging the headphones. My battery status is reading 66%.

Luckily I haven't had any issues with the unit dying on me while using but it is a shame that this issue hasn't been fixed yet.

I hope you guys have better luck than me.
Reply With Quote


  #21  
Old 11-08-2018, 06:46 AM
RoyRoy RoyRoy is offline
Registered User
 
Join Date: Feb 2016
Posts: 3
POST ID # = 979431
RoyRoy Reputation: 10
Default

Same problem here, yesterday it stopped at 93 prosent, at the lady told me it was done charging, I hope they can fix this asap, cause its not like this its gonna be when you buy an headset for 131,- usd.
Reply With Quote


  #22  
Old 11-16-2018, 03:21 PM
nyxmnemosyne nyxmnemosyne is offline
Registered User
nyxmnemosyne's PC Specs
 
Join Date: Nov 2018
Posts: 2
POST ID # = 980794
nyxmnemosyne Reputation: 10
Default

I have the same problem, I just bought mine 2 days ago and mine has the same problem, it won't go past 94%. I couldn't even submit a ticket because the corsair support page won't let me register and just kept showing an error.
Reply With Quote


  #23  
Old 11-24-2018, 04:14 PM
H1mself H1mself is offline
a reasonable man
H1mself's PC Specs
 
Join Date: Nov 2018
Posts: 1
POST ID # = 981875
H1mself Reputation: 10
Default

Quote:
Originally Posted by ifnt05 View Post
Have you guys tried charging it from the wall? Like using a phone charger or something like that?

If i plug it into my PC's USB 3.0 port it will charge to 80-85%, if i plug it into the wall with my phones fast-charger it goes up to 100%.

I guess the USB port on the PC isn't capable of charging it, or it just takes way too much time after the 80% mark.
^^^ I think this is the solve. If I plug mine into my USB 3.1 port, it charges to 93% and then tells me (literally in this case) "charging complete." At which point, with iCue Space open and the battery widget on display, I disconnected the micro end of the USB cable, and....93%.

However, when I plugged it (the USB cable) into my Anker multi-port "smart" charger and left it to fully charge again, the next time I turned the headset on it showed a 100% charge once more, so....try using a phone charger, or at least something more reliable than your computer's 2.x/3.x USB ports. At the very least, its a worthwhile troubleshooting step.
Reply With Quote


  #24  
Old 11-26-2018, 07:12 PM
Corsair Calico Jack's Avatar
Corsair Calico Jack Corsair Calico Jack is offline
Corsair Employee
 
Join Date: Oct 2016
Posts: 578
POST ID # = 982232
Corsair Calico Jack Reputation: 10
Default

There really are a few possibilities:

1. The battery needs to be reset and power cycled. On a Void Pro headset, this can be done by holding the Mute button for 15 seconds while the headset is powered on. On an HS70, let the battery die out and then charge it. That should fix the battery not reporting the correct charge.

2. The battery itself is faulty. If this is the case, we can provide a replacement through our support portal on support.corsair.com.

3. Windows is misreporting the battery charge. This just happens when the data is not updating correctly. Try powering the headset on and off, or restarting the computer. Using a different cable may help as well.

We don't generally go cheap on parts, and we keep an eye out for issues like these. As far as we know, there isn't any trending highly prevalent issue, but some failures should be expected. That being said, we'll get you set up as soon as possible if you create a ticket for the issue.
Reply With Quote


  #25  
Old 12-04-2018, 01:28 AM
Rob86 Rob86 is offline
Registered User
Rob86's PC Specs
 
Join Date: Mar 2018
Location: Toronto, Ontario, Canada
Posts: 26
POST ID # = 983487
Rob86 Reputation: 10
Default

Is it safe to charge the HS70 headset overnight? The manual says you should unplug the headset from the charger promptly after it is fully charged. So am I unable to charge it overnight when I go to bed or go to work for the day?
Reply With Quote


  #26  
Old 12-18-2018, 03:29 PM
Gahhruuba Gahhruuba is offline
Registered User
 
Join Date: Dec 2018
Posts: 1
POST ID # = 985993
Gahhruuba Reputation: 10
Default

Having the same issue... Pretty upsetting for a $70 headset that turns into a wired headset anyways.

Corsair may have lost me as a customer now, this headset has been unplugged at 100% and used until battery was dead. Clearly these batteries are faulty.
Reply With Quote


  #27  
Old 03-27-2019, 03:06 PM
andyliu1210 andyliu1210 is offline
Mr
andyliu1210's PC Specs
 
Join Date: Mar 2019
Posts: 1
POST ID # = 999202
andyliu1210 Reputation: 10
Default

Got my set today and I charged for roughly 2hours. iCue shows 100%. Will come back and update after a full cycle of use. However I'm mainly using for PS4.
Reply With Quote


  #28  
Old 04-30-2019, 12:23 PM
kermudgen kermudgen is offline
Registered User
 
Join Date: Aug 2015
Posts: 1
POST ID # = 1003088
kermudgen Reputation: 10
Default same ole same ole

Ugh. having same issue. already contacted support and they are following up promptly. I was thinking i was the only one with this issue. Anyways at least the powers that be seem to be trying to offer support.
Reply With Quote


  #29  
Old 05-01-2019, 10:03 PM
RhinoCan RhinoCan is offline
Registered User
 
Join Date: Apr 2019
Posts: 1
POST ID # = 1003289
RhinoCan Reputation: 10
Default

I'm having issues that are possibly related but much worse: mine won't charge at all. It's a new Corsair Void Pro RGB Wireless Premium Gaming Headset with Dolby Headphone 7.1. (Not sure what the model number is.)

I've had the headset for a couple of weeks and like it. I use it for work - at a small call centre - and it worked fine yesterday. Today, it wouldn't turn on despite being on the charging cable overnight. Even now, after a full day of charging it is completely dead. iCue says "Status/Battery: not connected". I've tried a different USB port but that didn't change anything. The LED doesn't come on to indicate charging, the lighting in the ear pieces (Corsair logo) is off and the earpieces don't make a peep when I press the power button.

Is there anything I can do to help myself here or do I need to exchange it at the store? It's still within the 30 day return warranty period.
Reply With Quote


  #30  
Old 05-02-2019, 12:09 PM
Corsair Notepad Corsair Notepad is offline
Corsair Employee
Corsair Notepad's PC Specs
 
Join Date: Nov 2018
Location: Fremont, CA
Posts: 281
POST ID # = 1003364
Corsair Notepad Reputation: 10
Default

Quote:
Originally Posted by RhinoCan View Post
I'm having issues that are possibly related but much worse: mine won't charge at all. It's a new Corsair Void Pro RGB Wireless Premium Gaming Headset with Dolby Headphone 7.1. (Not sure what the model number is.)

I've had the headset for a couple of weeks and like it. I use it for work - at a small call centre - and it worked fine yesterday. Today, it wouldn't turn on despite being on the charging cable overnight. Even now, after a full day of charging it is completely dead. iCue says "Status/Battery: not connected". I've tried a different USB port but that didn't change anything. The LED doesn't come on to indicate charging, the lighting in the ear pieces (Corsair logo) is off and the earpieces don't make a peep when I press the power button.

Is there anything I can do to help myself here or do I need to exchange it at the store? It's still within the 30 day return warranty period.
Press and hold the mute button for 30 seconds.
After releasing the mute button wait 15 seconds.
Now power the headset on and give it a test.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.