The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Closed Thread
 
Thread Tools Search this Thread Rating: Thread Rating: 72 votes, 5.00 average. Display Modes
  #256  
Old 04-04-2015, 08:35 PM
Tropicocity Tropicocity is offline
Registered User
Tropicocity's PC Specs
 
Join Date: Apr 2015
Posts: 5
POST ID # = 770651
Tropicocity Reputation: 10
Default

I registered just now for the same reason - whenever I launch steam, no matter what effect I have running, the lights freeze and steam takes literally ten times longer to load up (roughly 15-20 seconds as opposed to around 2).
How can this not be fixed yet :(
edit: i should note that I went out to buy this keyboard just today!


  #257  
Old 04-05-2015, 10:43 AM
Polio Polio is offline
Registered User
 
Join Date: Mar 2015
Posts: 4
POST ID # = 770741
Polio Reputation: 10
Default

OK so been running my replacement board for a couple of days.

All is good with steam when using the usb hub sor far.
Only problem now is that I want to send it back again for exactly the same issue as I did last time. Though right now only one of my keys can't display white any more.
Its more of a yellow, so the blue is dying again.

Any one else have this issue?

Just when I thought I was going to make my lighting profile I get a kick in the ≣ Menu key.


  #258  
Old 04-05-2015, 01:13 PM
Inheritance's Avatar
Inheritance Inheritance is offline
CORSAIR Beta Team
 
Join Date: Jul 2013
Location: Somewhere in Texas
Posts: 5,306
POST ID # = 770751
Inheritance Reputation: 70
Default

Quote:
Originally Posted by Tropicocity View Post
I registered just now for the same reason - whenever I launch steam, no matter what effect I have running, the lights freeze and steam takes literally ten times longer to load up (roughly 15-20 seconds as opposed to around 2).
How can this not be fixed yet :(
edit: i should note that I went out to buy this keyboard just today!
because its hard to debug a problem so few users have and it sometimes comes down to a driver or hardware issue which is even harder to resolve.
__________________
Colors of the RAINBOW shine so bright!
USER IS NOT A CORSAIR EMPLOYEE
Come Join My Discord =(^.^)= [iCUE Guide]
Corsair USER Forums is NOT Corsair Tech Support


  #259  
Old 04-05-2015, 08:26 PM
Tropicocity Tropicocity is offline
Registered User
Tropicocity's PC Specs
 
Join Date: Apr 2015
Posts: 5
POST ID # = 770805
Tropicocity Reputation: 10
Default

Quote:
Originally Posted by zheren159 View Post
because its hard to debug a problem so few users have and it sometimes comes down to a driver or hardware issue which is even harder to resolve.
Is it really that few an amount of users? I thought it was mostly everyone on steam?

I posted the previous message on Windows 8. I've since formatted and decided to go back to Win 7 to see if it were any different. Lo and behold, it was exactly the same - steam takes 20-30 seconds to load up and my current RGB lighting profile also freezes up.

I have tried a fix that someone posted before and I've found it to be 100% effective; simply run CUE with the default profile and no effect on (as in, all my keys are a static red except for the WASD keys and the arrows keys which fade from red to white and back).

This leads me to believe that it is something to do with the power required to drive a certain amount of LEDS through a fast switching colour cycle, as the standard one is not only minimal on changes (only 8 keys change at all), but also very slow in the speed in which the keys do change.

If it helps any, when on Win 8 I tried 2x USB 2.0, 1x USB 3.0, 2x USB 3.0, 1x 2.0+ 1x 3.0... no combination of ports would fix it. I would run it off of a powered USB hub if I could but I do not currently have one and would rather not spend the extra money just to see if it helps.

I hope Corsair are looking into this very seriously, as I believe it does affect most steam users :(


  #260  
Old 04-06-2015, 09:06 AM
Inheritance's Avatar
Inheritance Inheritance is offline
CORSAIR Beta Team
 
Join Date: Jul 2013
Location: Somewhere in Texas
Posts: 5,306
POST ID # = 770887
Inheritance Reputation: 70
Default

Quote:
Originally Posted by Tropicocity View Post
Is it really that few an amount of users? I thought it was mostly everyone on steam?

I posted the previous message on Windows 8. I've since formatted and decided to go back to Win 7 to see if it were any different. Lo and behold, it was exactly the same - steam takes 20-30 seconds to load up and my current RGB lighting profile also freezes up.

I have tried a fix that someone posted before and I've found it to be 100% effective; simply run CUE with the default profile and no effect on (as in, all my keys are a static red except for the WASD keys and the arrows keys which fade from red to white and back).

This leads me to believe that it is something to do with the power required to drive a certain amount of LEDS through a fast switching colour cycle, as the standard one is not only minimal on changes (only 8 keys change at all), but also very slow in the speed in which the keys do change.

If it helps any, when on Win 8 I tried 2x USB 2.0, 1x USB 3.0, 2x USB 3.0, 1x 2.0+ 1x 3.0... no combination of ports would fix it. I would run it off of a powered USB hub if I could but I do not currently have one and would rather not spend the extra money just to see if it helps.

I hope Corsair are looking into this very seriously, as I believe it does affect most steam users :(
It doesnt effect most users. Ive talked to Corsair James about this and its an issue that effects a select group of users, and most of the time its a hardware/ USB protocol issue. They are rewriting the protocol in order to resolve the Steam/CUE crashing.
__________________
Colors of the RAINBOW shine so bright!
USER IS NOT A CORSAIR EMPLOYEE
Come Join My Discord =(^.^)= [iCUE Guide]
Corsair USER Forums is NOT Corsair Tech Support


  #261  
Old 04-06-2015, 05:26 PM
terabyte's Avatar
terabyte terabyte is offline
CORSAIR Beta Team
terabyte's PC Specs
 
Join Date: Sep 2014
Location: Italy
Posts: 4,354
POST ID # = 771004
terabyte Reputation: 73
Default

I received my K70 RGB last week, I had a list of all the major issues which I checked my keyboard against and I have none (steam, caps freeze, unknown device, etc).

Here on forums you will see more often peoples posting about issues since those that have none rarely visit it.


  #262  
Old 04-07-2015, 12:57 PM
Elefantito Elefantito is offline
Registered User
 
Join Date: Mar 2015
Posts: 22
POST ID # = 771143
Elefantito Reputation: 15
Default

Quote:
Originally Posted by terabyte View Post
I received my K70 RGB last week, I had a list of all the major issues which I checked my keyboard against and I have none (steam, caps freeze, unknown device, etc).

Here on forums you will see more often peoples posting about issues since those that have none rarely visit it.
Are you using a Z97 motherboard? most issues seem to be related to that chipset.


  #263  
Old 04-07-2015, 01:13 PM
terabyte's Avatar
terabyte terabyte is offline
CORSAIR Beta Team
terabyte's PC Specs
 
Join Date: Sep 2014
Location: Italy
Posts: 4,354
POST ID # = 771146
terabyte Reputation: 73
Default

Quote:
Originally Posted by Elefantito View Post
Are you using a Z97 motherboard? most issues seem to be related to that chipset.
Nope, as you can see in my system specs I have an "Asus P7P55D-PRO". I do know a person with a Z97 chipset that does not have issues though.

It's true that Z97 chipset seem to be causing the most issues, but not all of them however.


  #264  
Old 04-07-2015, 01:26 PM
neofu neofu is offline
Registered User
neofu's PC Specs
 
Join Date: Jan 2015
Posts: 14
POST ID # = 771150
neofu Reputation: 10
Default

Quote:
Originally Posted by Tropicocity View Post
Is it really that few an amount of users? I thought it was mostly everyone on steam?
Yeah it is only a pretty small amount of people ... why should people even look in a support forum if everything is working and write it?

Well, I have to say that it got way better with the last software updates for me. The only time the keyboard crashes is when playing Codemasters games (namely F1 2014, Grid Autosport and Dirt 3). Then it crashes usually after about 1-5 minutes (yes, it's very random and sometimes I can even play half an hours and it works after that ^^). Also, it only happens when colors are changing. I recently got an XBox controller, which is plugged in at any time and it did't make things worse (since I can play with it, it actually made things better).

As a workaround for other people, you can add a second mode to your profile which you toggle with a key (for me it's the "WinLock" key) and doesn't have any type lighting or animations.


  #265  
Old 04-07-2015, 01:38 PM
remilton remilton is offline
Registered User
remilton's PC Specs
 
Join Date: Apr 2012
Posts: 122
POST ID # = 771151
remilton Reputation: 10
Default

If it were wide spread this forum would be absolutely swamped. There seems to be a small yet significant number of users with freezing and Steam issues. There's also a few disgruntled folks that are very vocal and post several time a day.

I check up here 2 or three times a week to see how the 16.8 million color update is coming along. Other than that my K95 RGB workd great,


  #266  
Old 04-07-2015, 05:05 PM
MaddBomber83's Avatar
MaddBomber83 MaddBomber83 is offline
Newb
MaddBomber83's PC Specs
 
Join Date: Oct 2007
Location: West Texas
Posts: 7
POST ID # = 771185
MaddBomber83 Reputation: 10
Send a message via MSN to MaddBomber83 Send a message via Skype™ to MaddBomber83
Default

Hello; so checking back into this thread to see if any updates.... I also don't think it is only related to steam.

I'll shoot another message to support then.

For my system, without steam running (disabled from startup) the simple mode rainbow mode stops going after a few minutes of use.

My last interaction with support (Jan?) indicated a steam issue with a firmware update in the works...


  #267  
Old 04-07-2015, 05:53 PM
MitchElwell MitchElwell is offline
Registered User
 
Join Date: Apr 2015
Posts: 1
POST ID # = 771191
MitchElwell Reputation: 10
Default CUE Crashing upon steam launch

Quote:
Originally Posted by K0nfuze View Post
I'm using the latest Steam(Not Beta). Latest K70 RGB firmware and using 1 USB 3.0 port. Windows 8.1 64bit. I opened steam and as soon as I hit login, my lighting stopped working. I unplugged my keyboard and opened Steam again and it once again froze the keyboard. I unplugged the keyboard again and open Steam and then it works normally. Steam is the only application i've been seeing that is causing this problem. I do this a forth time and then catch it on video.

https://www.youtube.com/watch?v=BlbJ...ature=youtu.be
This is exactly what is happening with me, along with the occasional crash on start up, i can live with that, but the steam issue has seriously got me considering returning the keyboard. Any news on the issue?


  #268  
Old 04-09-2015, 06:08 PM
TheExtra404 TheExtra404 is offline
Registered User
TheExtra404's PC Specs
 
Join Date: Apr 2015
Posts: 5
POST ID # = 771645
TheExtra404 Reputation: 10
Default

i just bought my keyboard today K65, and i have the same issue. Steam freezes and takes longer than expected to load and CUE stops working and the lighting freezes on the board until i reset it. I am glad that the fix has already been talked about and is currently being fixed. Other than that this keyboard is awesome. I dont play games that often so its not that big of an issue at this point for me.


  #269  
Old 04-09-2015, 08:29 PM
Corsair James's Avatar
Corsair James Corsair James is offline
iCUE Product Manager
 
Join Date: Oct 2013
Location: Fremont, CA
Posts: 4,491
POST ID # = 771689
Corsair James Reputation: 75
Default

When we're closer to release, I'll include a few more of you to test the new FW + SW to see if your freezing is resolved. From what we see in testing (internal and external), its MUCH better now to the point where it may be solved once and for all.


  #270  
Old 04-09-2015, 11:19 PM
egret85 egret85 is offline
Registered User
egret85's PC Specs
 
Join Date: Apr 2015
Posts: 25
POST ID # = 771714
egret85 Reputation: 10
Default

I just got a K95 RGB and am having the same issues with Steam and CUE. The lights constantly freeze and require cycling to BIOS mode and back to get it working. Even doing that sometimes takes a couple of times and multiple restarts if the CUE software to get things working again. I've tried with all combination of USB ports (2x USB 2.0, 1x USB 3.0, 1x USB 3.0/1x USB 2.0, 2x USB 3.0) and nothing seems to help with the freezing. Lighting also freezes if I repeatedly press or hold the capslock/numlock/scroll lock keys. Hoping this gets fixed soon because I really like the keyboard but these issues are so annoying.

Last edited by egret85; 04-09-2015 at 11:24 PM.


Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.