The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 44 votes, 5.00 average. Display Modes
  #31  
Old 10-18-2013, 01:40 PM
vexed vexed is offline
Registered User
vexed's PC Specs
 
Join Date: Apr 2012
Posts: 114
POST ID # = 679019
vexed Reputation: 20
Default

Quote:
Originally Posted by Purify View Post
Some people are lucky apparently. Mine don't work at all after the 8.1 update. :( How long will it be until this gets addressed?

i am also in the same boat as you, some people can get theirs to work using only 2.0 whereas mine doesn't make a sound, yet the mic works fine. i find it unacceptable with how long this has been out for release that no driver even if it is not MS certified has been published. So far my headset will remain nothing more than a £110 paper weight until a driver is released
Reply With Quote


  #32  
Old 10-18-2013, 03:18 PM
jaganram2003 jaganram2003 is offline
Registered User
 
Join Date: Jun 2013
Posts: 8
POST ID # = 679028
jaganram2003 Reputation: 10
Default

Same here just installed windows 8.1 today and my sound is gone mic works but i dont hear anything on headphones dont know why it takes so much time for the drivers :(
Reply With Quote


  #33  
Old 10-18-2013, 04:15 PM
DavidRappl DavidRappl is offline
Registered User
DavidRappl's PC Specs
 
Join Date: Apr 2013
Posts: 16
POST ID # = 679031
DavidRappl Reputation: 10
Default

I have the Corsair Vengeance 2000 and just installed Windows 8.1. The headset did not work at all, until I uninstalled the Realtek Audio drivers. Now I at least have sound, but no surround sound.

@Corsair: Can you give us a release date on the new drivers for Windows 8.1? Is this a mater of weeks, month or years / never?
Reply With Quote


  #34  
Old 10-18-2013, 08:13 PM
vexed vexed is offline
Registered User
vexed's PC Specs
 
Join Date: Apr 2012
Posts: 114
POST ID # = 679068
vexed Reputation: 20
Default

I have completely uninstalled the corsair headset software and the headset works in stereo mode (2.0) but its better than it not working at all until a official release / beta is done. im now happy it works once again
Reply With Quote


  #35  
Old 10-19-2013, 08:20 AM
raziel2710 raziel2710 is offline
Registered User
raziel2710's PC Specs
 
Join Date: Aug 2013
Posts: 4
POST ID # = 679110
raziel2710 Reputation: 10
Angry Very disappointed

I know Windows 8.1 Preview wasn't a full/stable release and Corsair had no obligation to fully support it. I understand and respect that. The companies that support my GPU/Keyboard/Mouse/standalone speakers etc. all had beta drivers for 8.1 Preview and now all have full release drivers for Windows 8.1 since it's official release this past week. The only thing I can't use properly are my Vengeance 1500s. I'm going back to Creative. Even their driver support is better than this...
Reply With Quote


  #36  
Old 10-19-2013, 08:55 AM
ShavedApe ShavedApe is offline
Registered User
ShavedApe's PC Specs
 
Join Date: Aug 2011
Posts: 62
POST ID # = 679113
ShavedApe Reputation: 10
Default

I find it laughable that it took 2 days post release to get a comment that incidentally is still not an apology. I find it laughable that the answer to this is to tell us just to use stereo mode and Microsoft default drivers until they can resolve it.

I paid for 7.1 audio, I already owned 2.0 audio capable headsets and speakers and could have saved myself some money if that was all I wanted or needed.

Windows 8.1 was not some surprise update that they had no idea was coming and while I understand the certification process may take a while many others managed to get their drivers ready in time for release.
At the very least give us access to the beta drivers so that we can still make use of our headsets the way they are meant to be used.

Last edited by ShavedApe; 10-19-2013 at 08:58 AM.
Reply With Quote


  #37  
Old 10-20-2013, 06:08 AM
TechKno TechKno is offline
Registered User
 
Join Date: Oct 2013
Posts: 1
POST ID # = 679212
TechKno Reputation: 10
Default

I have exactly the same problem. Is there any way to uninstall Windows 8.1 without a backup?
Reply With Quote


  #38  
Old 10-20-2013, 08:03 AM
vexed vexed is offline
Registered User
vexed's PC Specs
 
Join Date: Apr 2012
Posts: 114
POST ID # = 679214
vexed Reputation: 20
Default

Quote:
Originally Posted by TechKno View Post
I have exactly the same problem. Is there any way to uninstall Windows 8.1 without a backup?

only way is the format your pc otherwise im sure plenty of others would do this also.
Reply With Quote


  #39  
Old 10-20-2013, 09:30 AM
raziel2710 raziel2710 is offline
Registered User
raziel2710's PC Specs
 
Join Date: Aug 2013
Posts: 4
POST ID # = 679222
raziel2710 Reputation: 10
Default

Quote:
Originally Posted by raziel2710 View Post
I know Windows 8.1 Preview wasn't a full/stable release and Corsair had no obligation to fully support it. I understand and respect that. The companies that support my GPU/Keyboard/Mouse/standalone speakers etc. all had beta drivers for 8.1 Preview and now all have full release drivers for Windows 8.1 since it's official release this past week. The only thing I can't use properly are my Vengeance 1500s. I'm going back to Creative. Even their driver support is better than this...
Corsair, forgive my previous outburst. I got my 1500 working flawlessly in Windows 8.1. I completely uninstalled the drivers/software and reverted back to version 1.1 driver without using the 2.0.16 package.

If anybody wishes to try it: Run the 1.1 driver in Windows 7 compatibility mode and (very important) as administrator. Install as normal.

I am sorry I raged on this forum (it's not like me) but to be fair, even though I now have a fully working headset again, I still think we should have full release Win 8.1 drivers from Corsair at this stage.
Reply With Quote


  #40  
Old 10-20-2013, 10:10 AM
JAW81 JAW81 is offline
Registered User
 
Join Date: Oct 2013
Posts: 1
POST ID # = 679231
JAW81 Reputation: 10
Default

I just got my 2000 working by installing driver version "Vengeance2000SW_1_7_051512". It would be nice to have a updated version of the drivers but this will do for now.
Reply With Quote


  #41  
Old 10-27-2013, 12:44 PM
mcr1878 mcr1878 is offline
Registered User
mcr1878's PC Specs
 
Join Date: Oct 2013
Posts: 42
POST ID # = 680219
mcr1878 Reputation: 10
Default

Quote:
Originally Posted by raziel2710 View Post
Corsair, forgive my previous outburst. I got my 1500 working flawlessly in Windows 8.1. I completely uninstalled the drivers/software and reverted back to version 1.1 driver without using the 2.0.16 package.

If anybody wishes to try it: Run the 1.1 driver in Windows 7 compatibility mode and (very important) as administrator. Install as normal.

I am sorry I raged on this forum (it's not like me) but to be fair, even though I now have a fully working headset again, I still think we should have full release Win 8.1 drivers from Corsair at this stage.

I am going to try this "FIX" now myself.

Its annoying that CORSAIR did not publish this themselves when Windows 8.1 was released in full last week.

I am using the Corsair 1500 which is on the market here in the UK (I purchased mine 2 weeks ago). Technically it could be a breach of the unfair trading regulations if Corsair don't ensure they sell products that work as advertised.

I have massive respect for Corsair and have purchased their products extensively this year for my new build ('000s of £ )

Case, PSU and memory. Plus this headset which only was purchased because of their reputation.

But they need to ensure they keep up to date on the drivers and software. Especially on a major OS update.


Will try the "fix" administrator run above now and revert if it doesn't work.
Reply With Quote


  #42  
Old 10-27-2013, 01:57 PM
mcr1878 mcr1878 is offline
Registered User
mcr1878's PC Specs
 
Join Date: Oct 2013
Posts: 42
POST ID # = 680225
mcr1878 Reputation: 10
Default

No. That attempt did not work using v1.1 driver and compatibility.

I currently now have no sound on my headset having tried to revert back having un-installed and reinstalled v1.1.1 other than system sounds.

My browser and other programmes will not play any sounds.

So come on Corsair.

Alot of people are waiting on this or they have useless Corsair 1500 and 2000 headsets.
Reply With Quote


  #43  
Old 10-28-2013, 09:17 AM
ShavedApe ShavedApe is offline
Registered User
ShavedApe's PC Specs
 
Join Date: Aug 2011
Posts: 62
POST ID # = 680350
ShavedApe Reputation: 10
Default

Installing 1.1 is not a fix far from it, the sound quality is horrible some echoing mess that is clearly just 2.0 converted into simulated surround. I would rather listen on my desktop speakers than use that.

I cant believe that here we are so long after 8.1 was announced and then eventually went final and there isnt even a beta driver available as temporary fix.
Reply With Quote


  #44  
Old 10-30-2013, 04:06 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,268
POST ID # = 680679
RAM GUY Reputation: 10
Default

We're hoping to have a driver available in mid-November.
__________________
Support accounts and tickets can be created at https://support.corsair.com.
Reply With Quote


  #45  
Old 11-05-2013, 11:45 AM
warriorx51 warriorx51 is offline
Registered User
 
Join Date: Nov 2013
Posts: 1
POST ID # = 681457
warriorx51 Reputation: 10
Default

Can't afford an other deception on the next patchs for a 150€ Headset, not worth my time and money, nope.jpg.



Even if the Patch is released, I'm still going back to SteelSeries, sorry Corsair, I'm not blaming the dev. team or Guru here, but there is a big management problem over there that make the team look like incompetent worker taking their customer for fools.

Good headset>Drivers can't follow new OS's.

I will come back in a few years to check if they changed, otherwise, farewell...


Kind Regards.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.