The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-15-2018, 12:19 PM
LoneNoble LoneNoble is offline
Registered User
 
Join Date: Oct 2018
Posts: 4
POST ID # = 976493
LoneNoble Reputation: 10
Default Keys not displaying the correct colour

I have had this strafe for a long time now, and I haven't wanted to replace it.

It seems its finally kicked the bucket, the following keys display yellow:
-Alt GR
-Fn
-C
-X
-Z
-\
-SHIFT

And my left control key refuses to display any colour except red, turning itself off when my blue ripple effect passes over it...

I went to run a firmware update, but it says it doesn't have one, im also worried it may be a hardware issue...

I have attached 2 images demonstrating this issue, with the colour set to all white, but the keys showing up differently

Any insight corsair?
Reply With Quote


  #2  
Old 11-10-2018, 06:12 PM
edeescam edeescam is offline
Registered User
 
Join Date: Feb 2007
Posts: 34
POST ID # = 979833
edeescam Reputation: 10
Default

Same thing happened to my K70. I get a row of keys displaying green on boot up. I tried a soft reset, hard reset and nothing worked. I even took it apart but could see nothing wrong.

How old is your keyboard? Mine is 4 years old.
Reply With Quote


  #3  
Old 12-02-2018, 08:49 AM
LoneNoble LoneNoble is offline
Registered User
 
Join Date: Oct 2018
Posts: 4
POST ID # = 983100
LoneNoble Reputation: 10
Default

Quote:
Originally Posted by edeescam View Post
Same thing happened to my K70. I get a row of keys displaying green on boot up. I tried a soft reset, hard reset and nothing worked. I even took it apart but could see nothing wrong.

How old is your keyboard? Mine is 4 years old.
-----------------------------------------------------------------------------------------

Mine is closer to 2 years old now, shorter than I want the lifespan to be for an expensive keyboard like the strafe
Reply With Quote


  #4  
Old 12-04-2018, 12:07 PM
madcap123 madcap123 is offline
Registered User
 
Join Date: Mar 2016
Posts: 35
POST ID # = 983544
madcap123 Reputation: 10
Default

I imagine some of the leds inside of the rgb led have died. The problem I have with my k70 lights is that one or two won't match the others (assuming pure white), but it can change from key to key seemingly randomly (every few days). I imagine the problem is the controller, but I stopped caring so long as I can see them.

Last edited by madcap123; 12-04-2018 at 12:09 PM.
Reply With Quote


Reply

Tags
question, strafe. rgb keyboard, support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.