The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-06-2017, 10:55 PM
davidbdeath davidbdeath is offline
Registered User
 
Join Date: Mar 2017
Posts: 49
POST ID # = 914884
davidbdeath Reputation: 10
Default Dolby 7.1 USB Adapter

I bought a VOID Surround Hybrid Stereo Gaming Headset with Dolby 7.1 USB Adapter in March. I've barely used the USB adapter and now it's not working. It's not lighting up and the computer doesn't see it. Any ideas?
Reply With Quote


  #2  
Old 08-07-2017, 02:16 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 904
POST ID # = 915010
Corsair Nick Reputation: 39
Default

Have you tried plugging the dongle in to different USB ports on the motherboard? If it still doesn't detect, put in a support ticket on our support site, and one of our Technical Support reps can help you out with an RMA.

http://support.corsair.com/
Reply With Quote


  #3  
Old 08-13-2017, 01:49 PM
davidbdeath davidbdeath is offline
Registered User
 
Join Date: Mar 2017
Posts: 49
POST ID # = 916012
davidbdeath Reputation: 10
Default sadness

I put in a ticket 3 days ago and have heard nothing!!!!! I tried it on multiple computers and it didn't work.
Reply With Quote


  #4  
Old 08-15-2017, 02:09 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 904
POST ID # = 916276
Corsair Nick Reputation: 39
Default

Can you PM me your ticket number, and I'll look into this with our technical support staff?
Reply With Quote


  #5  
Old 08-22-2017, 10:41 AM
davidbdeath davidbdeath is offline
Registered User
 
Join Date: Mar 2017
Posts: 49
POST ID # = 917116
davidbdeath Reputation: 10
Default

Wow, maybe I just should never buy Corsair again. I thought Razer was bad but at least I get a response from their support department.
Reply With Quote


  #6  
Old 08-26-2017, 01:24 PM
davidbdeath davidbdeath is offline
Registered User
 
Join Date: Mar 2017
Posts: 49
POST ID # = 917600
davidbdeath Reputation: 10
Default Return Shipping

It's a little ridiculous to have to pay for return shipping on a product that was clearly defective.
Reply With Quote


  #7  
Old 07-07-2019, 02:43 PM
peterchiu.79 peterchiu.79 is offline
Registered User
peterchiu.79's PC Specs
 
Join Date: Jan 2019
Posts: 4
POST ID # = 1010532
peterchiu.79 Reputation: 10
Default HS60 mic not working

Quote:
Originally Posted by Corsair Nick View Post
Can you PM me your ticket number, and I'll look into this with our technical support staff?
Did this ever get resolved? I've got the same issue with my HS60 mic. I've tried EVERYTHING i've read on line. The headset works on my phone and I've tried my old headset on my computer and that works fine. I can only surmise its the USB adapter or its interface with windows. I have win 10 1903.
It was working fine and suddenly stopped with no changes to my PC. The first time this happened I was able to fix it by restarting the Windows Audio Service.
Now nothing works. I've tried checking privacy settings, default devices, installing drivers, rolling back drives, all USB ports etc...so many tries and nothing works. Is there a fundamental problem with these USB dongles?
I won't be getting a headset with one ever again that's for sure.

Please help!
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.