The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-21-2015, 02:52 PM
DN_Assassin DN_Assassin is offline
Registered User
DN_Assassin's PC Specs
 
Join Date: Sep 2015
Posts: 2
POST ID # = 809841
DN_Assassin Reputation: 10
Default H75 stand off screws (urgent)

I had been trying to install the Corsair H75 cpu liquid cooler for over an hour now, everything was going fine until it came to screwing those knobs on the stand off screws to hold them down. I got fustrated and then went to look at corsairs installation guide on how to do it correctly, I then saw that he was using different coloured stand off screws on his machine for the Intel 1155 socket then me, he was using sliver and I was using grey. I then realised that I had been using the AMD Stand off screws and that's why the knobs wouldn't screw all the way down. I then tried removing them so I could replace them but now I'm unable to unscrew the AMD standoff screws from my motherboard, this means I'm unable to do anything that involves my computer until I'm able to get the removed, what should I do? How can i remove the screws? Please help :(

Last edited by DN_Assassin; 09-21-2015 at 03:34 PM.
Reply With Quote


  #2  
Old 09-25-2015, 09:45 PM
Killer01ws6 Killer01ws6 is offline
Registered User
Killer01ws6's PC Specs
 
Join Date: Nov 2014
Posts: 28
POST ID # = 810567
Killer01ws6 Reputation: 10
Default

I imagine you have it fixed already..... But, if not..
I had to change out my backplate due to issues, I used my old H50 plate when I put the H75 on.. long story short, I had to change the plate out down the road.. same as you they would not come out.. a pair of small needle nose pliers did the trick...
put a slight pull on the pliers while turning and they came right out.. Seems post may go past end of its threading and then not want to back out.]

hope this helps.
Reply With Quote


  #3  
Old 09-25-2015, 10:18 PM
DN_Assassin DN_Assassin is offline
Registered User
DN_Assassin's PC Specs
 
Join Date: Sep 2015
Posts: 2
POST ID # = 810569
DN_Assassin Reputation: 10
Default

Quote:
Originally Posted by Killer01ws6 View Post
I imagine you have it fixed already..... But, if not..
I had to change out my backplate due to issues, I used my old H50 plate when I put the H75 on.. long story short, I had to change the plate out down the road.. same as you they would not come out.. a pair of small needle nose pliers did the trick...
put a slight pull on the pliers while turning and they came right out.. Seems post may go past end of its threading and then not want to back out.]

hope this helps.
Yeah I fixed it the day after I actually posted this as a person on another site advised me to use pliers to unscrew them, seeing as how they would have more grip and strength on the screws and I managed to unscrew them in the end and put the right ones in and get my H75 up and running. Thanks anyway :)
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.