The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-30-2019, 11:51 PM
Afumaru Afumaru is offline
Registered User
Afumaru's PC Specs
 
Join Date: Aug 2019
Posts: 1
POST ID # = 1016238
Afumaru Reputation: 10
Default This is a major problem, please fix this soon.

I have recently purchased the Corsair HS70 Wireless headphones, i feel as though they are something i like, which i do, but when i try to connect my headphones to the software to manage the sounds properties, nothing comes up, i have tried many routes in fixing it and tried troubleshooting it. i am not trying to risk turning these headphones into a brick (meaning they no longer work.) because of some faulty software that could use a lot of tuning for it's multiple uses, for now i am stuck with stock sounds, i cannot manage any filters or EQ, this needs to change soon, i value these headphones, i'd like to see these do great things for my Gaming experience, and the iCUE software, takes that chance away from it completely. Thank you for your time. Please fix this soon.
Attached Images
File Type: png Screenshot_112.png (1.16 MB, 22 views)
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.