The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-15-2019, 11:02 AM
bigdave2019 bigdave2019 is offline
Registered User
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1021340
bigdave2019 Reputation: 10
Default Strafe RGB

Just today I noticed my Strafe has started doing this.
Keys stuck red, and flickering. Had it around a year. All the keys work fine.
I've tried deleting and reinstalling iCUE, forcing updates through it.
Both leads in different USB sockets, just the keyboard lead in different USB sockets.
Unplugged it, and pressed the ESC key then plugged it back in.
Creating new profiles, deleting profiles.

Can anyone help?

Thanks.
Reply With Quote


  #2  
Old 10-15-2019, 03:43 PM
Corsair Elito Corsair Elito is offline
Corsair Employee
 
Join Date: Sep 2019
Posts: 23
POST ID # = 1021370
Corsair Elito Reputation: 10
Default

Hi,

I would suggest getting in contact with technical support a creating a ticket. They can help diagnose the problem and assist with an replacement if your under warranty.

https://help.corsair.com/hc/en-us/requests/new

Kind regards,
Reply With Quote


  #3  
Old 10-17-2019, 04:42 AM
bigdave2019 bigdave2019 is offline
Registered User
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1021539
bigdave2019 Reputation: 10
Default

I've been in touch, unfortunately I've no idea where or when I bought it.
I tend not to keep receipts, unless stuff costs lots of money!
Reply With Quote


  #4  
Old 10-17-2019, 04:56 AM
bigdave2019 bigdave2019 is offline
Registered User
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1021540
bigdave2019 Reputation: 10
Default

I've found the Paypal record of purchase, 2017.
So I'm guessing way out of warranty.
Reply With Quote


  #5  
Old 10-17-2019, 03:46 PM
bigdave2019 bigdave2019 is offline
Registered User
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1021593
bigdave2019 Reputation: 10
Default

I've had a chat with customer support, tried the solutions provided. Including the firmware delete and change via the keyboard.
No dice, still got keys that won't show blue colours and flicker.

Oh well.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.