View Single Post
  #4  
Old 06-15-2017, 05:41 PM
CCFAN's Avatar
CCFAN CCFAN is offline
Registered User
CCFAN's PC Specs
 
Join Date: May 2017
Posts: 20
POST ID # = 908174
CCFAN Reputation: 10
Question

Quote:
Originally Posted by ZeroFatal1ty View Post
cxmachi, you are not alone.

I'm having the exact same issue with the same K70 RGB LUX and Maximus IX Formula. Sounds like a USB handling exception.

I already submitted a support ticket, so to spare the details I'll paste it here.... Lemme know if this is spot on.



Ticket Description:

Cue 2 and my K70 RGB LUX has issues when opening Steam and launching games (from other clients too). When Steam hangs, I can flip the polling-rate switch and it stops hanging. Steam, Need for speed 2015, Mass Effect Andromeda, Watchdogs, The Division, DOOM, Ghost Recon Wildlands, and others all hang on launch and close due to this issue. Hang time, appcrash, and timeout can last 30 seconds to 2 minutes.

This issue doesn't occur with K70 unplugged OR Cue 2 uninstalled. Everything loads instantaneously.

Steam and others function fine with another keyboard and Cue and the K70 performs fine without Cue installed.

This was with a clean OS, clean steam install, and clean CUE install with just drivers. All were latest versions, including motherboard BIOS. I've tried many USB configurations.

The problem seems to occur when CUE installs the "Virtual USB composite device" and "Corsair BUS." Then the keyboard has trouble with Steam/others.

I also have the Glaive, VOID Wireless, and Polaris mouse pad.

This link -> http://forum.corsair.com/v3/showthread.php?t=168442 - describes the problem identically.

Specs: Asus Maximus IX Formula, Intel i7 7700K, Corsair Vengeance RGB 32GB 3466Mhz, ASUS GTX1080ti OC, Samsung 960 Pro 1TB NMVe, Corsair HX1000i PSU.

BIOS Settings are all AUTO except CSM disabled. Legacy USB set to AUTO



Sound Familiar?
Does it happen on K70 series keyboards only?

I'm planning to buy a K70 LUX RGB but now the plan is delayed after hearing so much similar reports.

I have an M65 Pro RGB mouse working and the CUE works normally; your problem does not occur on my laptop and mouse currently.

If it is only caused by the K70 keyboard, I would not buy it. And I also heard about the LED noise of K70. Bad news.
Reply With Quote