View Single Post
  #2  
Old 07-29-2019, 12:45 PM
hastegag hastegag is offline
Registered User
hastegag's PC Specs
 
Join Date: Dec 2016
Location: Northeast US
Posts: 914
POST ID # = 1012988
hastegag Reputation: 20
Default

I can no longer see certain Mkeys in SDK events in this release on one of two computers, and even rolling back versions doesn't seem to fix. Any suggestions?

It does not show up even using a second scimitar to test on a separate USB port and running the latest SDK events example, no M keys show up. I am going to try again when I get home but do you think this could be a corrupted driver? the keys work inside icue, just not via the sdk, even if they are unbound/unassigned in icue.


!!!EDIT!!!:
after many hours of frenzied attempts to diagnose, i am 95% sure it was USB crowding either during the install or something like that preventing the second HID driver.

That being said, nothing had changed other than the update to icue. The same results were happening with a second scimitar attached to different usb port, with or without the other scimitar attached. After a clean uninstall without wiping contents, rebooting, new reinstall of latest version (without any programs running and without Infinniton and Streamdeck plugged in and pulling everything else on USB but keyboard during install and manually uninstalling all mouse hid device drivers before install) I was able to get the side buttons to work again. So grateful! I rely on it so much. Events example now works as anticipated and I will have to take a look at updating my register callback modifications to the events subscription for future compatibility.

Last edited by hastegag; 07-29-2019 at 07:33 PM. Reason: update
Reply With Quote