View Single Post
  #1  
Old 03-02-2019, 12:43 AM
cpynch cpynch is offline
Registered User
cpynch's PC Specs
 
Join Date: Mar 2019
Posts: 2
POST ID # = 996062
cpynch Reputation: 10
Default Spec Omega Ligning Node problems

I am having some weird issues with my new case.

I've got my fans hooked up to the hub, and the hub connected to to the Lighting node in Ch1. Ch2 is controlling the LED strip on the front of the case.

The LED strip lights up on startup, but no case fans RGB works.

I've tried disconnecting them one by one, and no luck.

Also, every time I reboot the controller loads as "CRP DISABLD", and shows me the firmware. If I eject the drive VIA windows explorer and reboot, it just loads as a USB drive again.

It doesn't show up in LINK (4.9.9.3) or in ICue, (3.13.94).'

After I eject the device, it just shows up as "USB Mass storage device", but says it's waiting to be ejected. I disconnected the USB from the node to see if that would make the node register again, but to no avail.

Rebooting after ejecting, disconnecting, and reconnecting has no effect either.

I'm starting to think it's defective or the firmware is bad and needs replacing.

Running out of ideas, nothing I have done has gotten this device to register including plugging into a different USB header.

Any help is appreciated....

I should mention, that once just one time, when I was assembling the PC, I tested it with no monitor or peripherals plugged in and the RGB portion of the fans worked for about 30 seconds. Then they shut off.

That's the only time I've seen the RGB work, and it was fleeting at best.

I just re-installed windows and have bare bones drivers, as for some reason after attempting to get this to work windows wouldn't load. This has happened twice. So, I've re-installed windows twice tonight.

Corsair Spec Omega RGB (doesn't show up in iCUE)
i5 9600K
MSI Gaming Edge AC Z390 Mobo
32 GB G.Skilll Trident RAM
Corsair H100i Pro (shows up in iCUE)
K70 Keyboard (shows up in iCUE)
ZOTAC RTX 2080 Amp Extreme
EVGA GQ 1000W Gold PSU
Samsung 970 PRO M.2 512gb
Samsung 850 EVO 256gb
Samsung 840 EVO 128gb

Seems like I might have a defective Lighting node, if I could get a different copy of the firmware I'd love to try it; just a replacement for the file that's currently installed so I can see if it's corrupted. Any help is greatly appreciated.

Thanks for reading!

Last edited by cpynch; 03-02-2019 at 12:45 AM.
Reply With Quote