The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   K95 RGB K95 Stopped working with CUE/iCUE (https://forum.corsair.com/forums/showthread.php?t=186112)

LittleMikey 03-12-2019 07:33 AM

K95 Stopped working with CUE/iCUE
 
Hi everyone.

So the other day my K95 stopped working some reason. I worked out that if I close CUE and plug in the keyboard again it seems to work fine, but as soon as I launch CUE again it stops working. It looks like it isn't being picked up as a device. I tried updating CUE but that didn't work, so I downloaded the new iCUE software but that doesn't work either. Does anyone know how I can fix this?

xMacias 03-12-2019 12:46 PM

Is your keyboard still able to type when it "stops working"?

I'm assuming iCUE does not see your device at all, so can you try fully uninstalling iCUE and then reinstall?

LittleMikey 03-12-2019 11:38 PM

Quote:

Originally Posted by xMacias (Post 997393)
Is your keyboard still able to type when it "stops working"?

I'm assuming iCUE does not see your device at all, so can you try fully uninstalling iCUE and then reinstall?

Hi sorry for being unclear, I am not able to type at all with the iCUE/CUE software running. And I have already tried reinstalling the software.

Spunkymanker 09-17-2019 02:24 PM

I just starting having exactly the same issue. Did you ever find a solution?
The keyboard (K95 RGB) works fine until I open icue. As soon as Icue is running, the keyboard disconnects. I can hear the windows disconnect sound, and the keyboard vanishes from device manager. Lights go out, and it doesn't work anymore. If I kill icue and replug the keyboard, it works fine again.

It was working fine with icue yesterday.
I have tried uninstalling and reinstalling icue as well.

Spunkymanker 09-18-2019 12:14 PM

I've done a little more troubleshooting, and have found some new information.
I did a soft reset on the keyboard by holding ESC while connecting the keyboard. This reset my lighting to factory (as far as I can tell). I still have the same issues with icue. I also noted that now, if I press M1 or M2, it switches profiles as normal. If I hit M3 or the 'dim'/lighting key, the keyboard basically turns off. I hear it disconnect in windows, and it goes dark and dead. Replugging it works again until I 'trigger' it.

Spunkymanker 09-18-2019 12:50 PM

More strange behavior. I connect the keyboard to another PC (which has never had icue) and it works just fine. I can press m1,m2,m3, and the dimmer button and it works fine.
Plug it back into the original pc, and the keyboard lights up on 'm3'. Windows does not recognize the keyboard at all. Nothing happens when pressing m1,m2, m3, etc. Unplug and replug, same.
Did another soft reset, and it's back to the previous problem - working fine on m1 or m2, but press m3 or dimmer, and it's gone again.
Ugh..

Spunkymanker 09-24-2019 01:42 PM

Might also note that on startup, the keyboard is not detected and does not work. Replugging it after windows startup makes it work again.
This makes me think it's driver issues, but not sure where to go from here.

David Butler 09-26-2019 05:44 PM

I am having the EXACT same issue as you describe with my K95 Plat. Just started since the last iCue update. It bricks and you have to unplug/replug until the next time, which is always in the middle of a game, requiring a power button reboot. Mine is 6 months old and has been awesome until the last driver update.

Spunkymanker 09-28-2019 12:54 AM

Yeah, so far no luck for me. It works very consistently unless icue is running or I press the 'm3' key. Very odd. Has to be driver related, but I have not been able to pin it down.

Spunkymanker 09-28-2019 12:56 AM

I was using icue 3.18.xxx I believe when the issue started. Upgraded to 3.19 to try to fix, but no luck. 3.20.80 is downloading now to test.

Spunkymanker 09-29-2019 11:19 AM

The updated version did not fix or change the symptoms at all. *sigh*

Spunkymanker 10-20-2019 01:10 AM

Odd.. I haven't changed or troubleshot anything.. but now it works fine.. ??? Just started working on its own a couple days ago.

Golden 01-08-2020 09:57 AM

My keyboard have the same issue.
It started a week ago and now I am using it with iCUE uninstalled.
Every day I am looking for a solution, but with no luck.

I even opened a ticket, but the support is useless... I told them that I have tried everything (even the soft reset) and on their reply, they suggest to try soft reset... USELESS!!!

So now I am hoping for a fix, because I am unable to use the keyboard features at all... If you have any ideas please share them with me.


All times are GMT -4. The time now is 10:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.