The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Cases (https://forum.corsair.com/forums/forumdisplay.php?f=189)
-   -   Light not working (https://forum.corsair.com/forums/showthread.php?t=181661)

Mr_reese12 10-09-2018 01:46 AM

Light not working
 
2 Attachment(s)
I recently purchased a Corsair Crystal Series 570x White and i'm having problems with the led in the power button and the Corsair logo on the front not lighting up. I'm not sure if they are just broken or if I have the power wires in the wrong spot, I was wondering if you could help me figure it out? Thanks!

Zotty 10-09-2018 02:47 AM

Hi buddy...

the Corsair Logo and Front sail Logo are Sata Powered.... make sure its plugged in... as for the power button LED.. try reversing the polarity its pin connectors......

Mr_reese12 10-09-2018 04:17 AM

Ok I will try that and let you know, by looking at my pictures of the motherboard do you know if the top row of pins are positive and the bottom negative or are the positive and negative on the same row right next to each other? Thanks!

Zotty 10-09-2018 04:27 AM

Asus Z370-E right ?



http://i.imgur.com/GBQgt0Gl.png

that picture is in the supplied manual that comes with your Motherboard.... section 1-17

Zotty 10-09-2018 04:30 AM

Looks like you have the PLED plugged into the wrong pins dude

Mr_reese12 10-09-2018 04:51 AM

Thanks for the diagram! Sorry I should have checked for that first! I have plugged the PLED now into the correct locations and still nothing, as for the sata power I will have to get back to you on that as for I will check on that tomorrow and let you know. Thanks!

Zotty 10-09-2018 05:04 AM

Quote:

Originally Posted by Mr_reese12 (Post 975675)
I have plugged the PLED now into the correct locations and still nothing,

you have 2 pled locations.. tried both?.. or indeed flipped the polarity... unless you damaged the LED when it was on the 5v+ and neg speaker pins........

Mr_reese12 10-09-2018 06:03 AM

i haven't tried the other location but i will, and that's what I was also thinking that I might have accidentally fried it :(

Mr_reese12 10-09-2018 06:04 AM

and yes I tried flipping the polarity but nothing

Zotty 10-09-2018 06:13 AM

good luck dude.....

Mr_reese12 10-09-2018 08:39 AM

Alright so I think I have my conclusion, trying the other PLED location did not work either, so I think that I fried the LED's in the sail and maybe even in the power button. I ruled out the sata cords connected to the molex that goes to my PSU, they are plugged in and not loose. So my next thing is replacing the LED's, i'm thinking that I would have to find some on amazon or do you think I could get two from Corsair? Thanks!

Zotty 10-09-2018 11:43 AM

Try opening a ticket.. explain whats happened,, maybe they can help you,

Click Support Ticket System at the top of this page

Corsair Caliente 10-09-2018 05:12 PM

Hey Mr_reese12,

At this point go ahead and submit a ticket on our support page. We can usually replace most parts and got plenty of 570X stuff.

Thanks Zotty for helping him so far.

Mr_reese12 10-09-2018 09:01 PM

Alright I submitted a ticket. Thank You, and Thank You very much Zotty you were a great help!

Zotty 10-10-2018 12:17 AM

No worries dude.... hope you get sorted and good luck on your quest ;) :D


All times are GMT -4. The time now is 09:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.