The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   RGB Corsair Scimitar Pro (https://forum.corsair.com/forums/showthread.php?t=179991)

AlphaSkywalrus 08-03-2018 01:25 AM

RGB Corsair Scimitar Pro
 
Hello, I am AlphaSkywalrus a newer user who has sought the knowledge to possibly fix my mouse before getting a new mouse. Recently within the past week my 3 month old Scimitar has started malfuctioning, When I play games the mouse it self does not shut off or disconnects (At least the lights don't turn off) it does a weird profile switch and it stops working for a little under a second, I deleted the other profiles in attempt to avoid the profile switch but it still does it. I disabled all but 2 dpi settings and it retains those dpi's after the switch. I only have corsair peripherals so software programs would not interfere (Corsair Strafe MK.2, Corsair Void Pro RGB Wireless) I can temporarily fix this "Malfunction" by forcing the mouse to update but it lasts for the maximum amount of time of 10 minutes before Malfunctioning again. I have uninstalled the program, and I have even completely reset my computer, I have switched usbs and even used a usb hub external of the computer and the usb attached to the Strafe MK.2 keyboard, The other 2 peripherals have not malfunctioned, it is only the scimitar, I have recently purchased the strafe, but the void pro i have had for about 9 months. I really like this mouse and I don't want to get rid of it unless needed to, tis why I come to the sacred grounds.

Corsair Lettuce 08-03-2018 10:28 AM

Are you currently on CUE or iCUE? Try running a repair or reinstall of the program and a soft-reset on the mouse. Unplug the mouse, hold down the left and right mouse buttons, plug the unit back in and let go of the buttons after about 5 seconds and let the mouse reinitialize.

AlphaSkywalrus 08-03-2018 07:31 PM

I am currently using Icue, and after doing the steps that you have instructed, it still malfunctions, I found another way to delay the malfunction or reset the mouse so it gives me a little bit more time. If I change the polling rate in the settings for the mouse it does the weird little profile switch and then the icon on the mouse indicating that it was malfunctioning (A yellow triangle with an Exclamation point) disappeared. It is only a temporary fix. (I have noticed it only happens when i play fps games)

Corsair Hotpot 08-06-2018 03:43 PM

Sorry to hear that the repair of the software didn't fix this issue. Generally it would be a driver issue that needs to be reinstalled to fix the malfunction but if it didn't help I recommend making a ticket on our support site and our Technical Support team can assist you further.


All times are GMT -4. The time now is 06:37 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.