The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   New K95 RGB stops sound after a while and windows does not shut down properly? (https://forum.corsair.com/forums/showthread.php?t=133059)

Inksie 10-04-2014 06:13 PM

New K95 RGB stops sound after a while and windows does not shut down properly?
 
New user here! Hi!

So, just recently upgraded(?) from my Razer Blackwidow Ultimate to the Corsair K95 RGB keyboard. Plugged both USBs in, seemed to work okay. A couple of dim LEDs (which I am inquiring about to the seller in hopes to get a replacement).

My main problem is, however, that my keyboard seems to want to make my PC go array and after about 30 minutes or so, my sound will cut off, youtube will not play, skype will crash and my only solution to this is to shut the computer down. However, my PC doesn't shut down properly and just sits on the "shutting down" screen.

This has never happened before I installed my new keyboard and its software, so I went back to using my Blackwidow. Sound is normal, shutting down is fine and nothing malfunctions while using my old keyboard.

I was wondering if anybody could shed light on my situation and possibly help me with a solution? I think this keyboard is absolutely stunning and would hate to have to give up on it because it doesn't function with my PC.

ANY help is greatly appreciated! :)

terabyte 10-04-2014 06:30 PM

Have you uninstalled your old keyboard drivers before installing the CUE software?

Inksie 10-05-2014 01:51 AM

I didn't install any Razer software as I recently built this PC and at the time didn't really feel the need to have it. :(

P00P34 10-05-2014 11:31 AM

It could very much just be firmware issues. Wait for a new update and it might be fixed. Also, try connecting the USB with a keyboard symbol on it to a USB 3.0 port. I've seen reports that doing so has helped. Also, if you're talking about 1-9 looking dim, Tek Syndicate said so as well. I was told they have to plant a red, blue and green led inside the stem, but I haven't asked an employee. Honestly, best solution is to contact an employee or staff member directly.

Inksie 10-05-2014 12:08 PM

The G key and # key are dim... they're not completely off because I can see lighting under them but they are more dim than the others.

Also, I live in the UK so it has the UK/EU layout I think. I don't know what Tek Syndicate is?

P00P34 10-05-2014 12:11 PM

Dim as in a less powerful color or a whiter color than the others? If it's a whiter color, check if you selected a lighter color in the software. If it's the default colors from when you plug it in, then it could be firmware or a DOA. If you are using software, I think you have individually adjust brightness, not sure. I don't know much of the layout, I just know you have a much bigger enter key. Tek Syndicate is a YouTube channel.

Inksie 10-05-2014 12:19 PM

It's the default colours. :( I've tried adjusting the brightness of these keys and they are all 100%. Ughhh, this sucks. I spent 160 on this keyboard and I haven't even been able to use it for the past 2 days since the people I bought it from don't operate on weekends.

Thanks for your help, anyway! I have been hearing that they are coming out with a firmware update end of this week (so today?) so maybe if I try that out and see if it helps any.

MesaMitch 10-05-2014 01:58 PM

its so strange that you posted this.
this also happened to me last night

i was doing my taxes last night
while listening to spotify on my schiit modi and magni and sennheiser hd8 dj headphones

some how some way keyboard froze all of a sudden
spotify crashed
my default driver changed to my sound blaster z sound card
went to full volume and made this super loud buzzing sound thank god the kids where up

had to restart my computer unplug the keyboard because the keyboard board was froze in the state that it was in

after i done that it was fine? but really strange how that happened

Inksie 10-05-2014 05:40 PM

Yeah, I have the Sennheiser 363d headphones and they completely go out after 30 minutes or so of the keyboard being plugged in. I'm really hoping it's the firmware and that it needs to be updated. Have they come out with anything yet?

DarkAgent 10-05-2014 05:59 PM

I have alot of issues with the K95 RGB but it does not seem to affect the system or it's stability. So far...

It's the CUE software I have issues with and really getting the software to consistently recognize the device without saying malfunction. Generally & consistently I can't get the CUE software to work for me and allow me to change any of the keyboards settings / colors

Inksie 10-05-2014 06:20 PM

That's happening with me right now. I decided to give the keyboard another go and now the CUE isn't working effectively for me now. I can't change any of the colours, nothing.

Inksie 10-05-2014 06:20 PM

First time going to Corsair with their keyboards and so far my opinion is bleak.

wobblyheadedbob 11-05-2014 12:08 PM

You need to update your BIOS. I know. Weird.

I had similar problems with my K95 when I first set it up, in some instances the machine wouldn't even reach the boot up screen.


All times are GMT -4. The time now is 04:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.