Jump to content

Search the Community

Showing results for tags 'wont turn on'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 3 results

  1. My headset has been working perfectly fine, until about 3 weeks ago. My headset wouldn't charge. I figured out that the input was kind of broken. I can charge the headset if I adjust the cable to a certain position. Today I realised that the headset won't even turn on. I've tried doing a soft reset as said on your support page, but that didn't work. And I charged the headset fully yesterday evening so I know that the battery isn't dead. One more thing, I've noticed that the battery drains very fast from 100-40% but then slow down. I payed about 150 euro for this headset, and to be honest im disappointed that they didn't even last a year..
  2. Been using my headset for about a month, battery was low last night and my wife turned it off and plugged it in. Today I get home from work and it wont turn on won't reset with the 20s hold down of the mute button, no charge light...nothing. I'd say it was dead but I plug it into the pc and it registers as Avnera AV6302. I use this 4 days a week for work as my phone and music, so I'm charging it every 2 or 3 days and never had an issue....:mad:
  3. My void RGB had a still blue light on the right headphone and when i turned it on and off it would just stay. I charged it for a bit so it would turn off, now it has just completely stopped working. The headset doesnt turn on
×
×
  • Create New...