Jump to content
Corsair Community

Search the Community

Showing results for tags 'tech issue'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 4 results

  1. http://imgur.com/gallery/dYQcVII I have RMA a SF600 and got a refurbished unit. It has been working fine for a few months but recently iv noticed a wired sound coming from it. This noise is quiet and happens occasionally. Should I be concerned?
  2. http://imgur.com/gallery/dYQcVII I have RMA a SF600 and got a refurbished unit. It has been working fine for a few months but recently iv noticed a wierd sound coming from it. This noise is quiet and happens occasionally. Should I be concerned?
  3. so I recently bought a corsair k63 wireless + lapboard and it randomly doesn't register me typing sometimes (on either wireless or bluetooth) or it will register one keypress as loads i.e. ttttttttttttttt. I saw a post talking about holding esc while turning on to factory reset, this seems to have solved the issue, however, as it happens randomly I'm not sure so posting here if there is some other known required fix for this issue.
  4. Hi All, So 2 weeks ago I took on the task of building a new pc (last one built was in 2014) so I purchased everything in my CP profile and put it all together. Once I had everything built as everyone can appreciate your overly ecstatic. I took photos to share on social media and with friends and family who also have an interest in the computer scene. Everything was good until one person mentioned that one of the sticks of ram was not lighting up on the photo i had sent. So this is my dilema. I have moved the ram from one slot to another and still no change. I have looked at icue and it is registered as being lit up on there and my mobo is seeing it as well i have full funcitonality of the ram itself just not the rgb lighting. The ram stick in question is just flashing red every now and then and its at the top and bottom of the sticks. :( I have sent a support query to corsair to see what they have to say, but what are your thoughts ? I have attached photos for your to review also.
×
×
  • Create New...