Jump to content
Corsair Community

Search the Community

Showing results for tags 'support not working'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Location


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 3 results

  1. Hello everybody! End of 2018 I had problems with my Vengeance 4GB RAM-Modules, so I tested them and after finding an Error with memtest I opened up a Ticket with the mentioned Ticket No. After getting an RMA Number I sent in the defective Modules (while only one was defective I sent in both, as I bought them as a Kit). In my Ticket statusbar I could see that they arrived at the 8th of january 2019. Since then nothing happens! Now - suddenly - the ticket was closed!! The Livechat is offline for days now, the international phonenumber gives me no connection, and it seems that there is no possibility to contact anybody from the support. Now it seems that my last hope for getting contact to someone who is in charge is this Forum. I must confess that I feel a little bit like beeing ripped off and hope that there is someone who could help me getting my new RAM-Modules. As I'm a 3D-Artist I really need every GB RAM for my work and working with only 8GBs is somewhat often slow and frustrating!
  2. I was just wondering if I was sent the right firmware for my K70 RGB Rapidfire. I was instructed to hard reset my K70 RGB Rapidfire by support. In order to do this, they sent my a zip file. The zip file is named "K70RAPIDFIRE_V205.zip". Doing the hard reset, CUE now just recognizes my keyboard as only K70 Rapidfire but before it recognizes it as K70 RGB Rapidfire. I think that this zip file/firmware is not the correct firmware for my K70 RGB Rapidfire because I saw in the corsair reddit that there is a zip file named "K70RGBRAPIDFIRE_V205.zip". Long story short, is "K70RAPIDFIRE_V205.zip" the right firmware for my K70 RGB Rapidfire. Or it's not?
  3. hello, i have a problem regarding the corsair support site. for some odd reason it doesn't seem to work properly, i can't even create an account. if i try to it states an error code and tells me to contact the support, which i obviously can't. please help me, thanks in advance
×
×
  • Create New...