Jump to content
Corsair Community

Search the Community

Showing results for tags 'not switching profiles'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • iCUE

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 1 result

  1. Hi everyone, This is my first post here. I signed up because I was unable to find a solution to this through a fair amount of google searching, so please don't crucify me if I've missed a thread about it. :) Recently I've picked up a set of new Corsair peripherals, a K95 Platinum RGB keyboard and Glaive RGB Aluminium mouse. Both of these products seem pretty good to me minus a couple small issues. Regarding the keyboard (the issue in the title), I am finding that although everything works as it should initially, it eventually stops auto switching to profiles that are linked to applications after my computer has been on for a while. It is worth noting that the mouse still appears to switch automatically when this occurs, and switching manually using the profile button on the keyboard still works. Restarting CUE does not fix the issue, so far rebooting the PC has been the only thing that resolves it temporarily. I usually leave my PC running most of the day and this issue only occurs around once or twice a day. I also notice (usually in my peripheral vision) that every so often a random key will flicker white once (they are currently backlit red) but it happens so fast I barely catch it. Regarding the mouse, I've had no glitches or anything but the back/forward buttons on the side are super flimsy on the one I got, they also stick when you press them in firmly and take a second to pop back out once released. I usually play FPS (generally TitanFall 2) and map melee to the back button, so this issue bothers me quite a bit. I haven't been able to compare this to any other glaives to determine if it is a design flaw or not, so it would be good to know what other glaive owners experiences are with these buttons. At this point I intend to take it back to the store I bought it from and compare it to another one on the shelf. Thanks in advance for any help/advice you can provide.
×
×
  • Create New...