Jump to content
Corsair Community

Search the Community

Showing results for tags 'leak'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Location


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 3 results

  1. After 2 weeks of install, the pump module started to leak from the side screw. Did anyone ever experience this? Luckily the leak was small, and there was a small puddle of fluid sitting on top of RTX3090 and luckily it wasn't damaged. Needless to say, the PC has been turned off ever since. Anyone experienced this? This to me looks like a manufacturing flaw. Surprising considering this was bought from Corsair's own website.
  2. Hi everyone ! I'm the possessor of a corsair hydro series h105 since may 2014, last week I've noticed a stain on my GPU, so I got the h105 out of my case and cleaned it a bit. I didn't liked what I saw, it looked like there was a little leak from the radiator itself. So now I'm scared to mount it again, what if it go crazy spitting coolant everywhere in my case ? Since the AIO was baught in 2014 my warranty may be ended and I don't want to loose my brand new GPU. So here's my question : does this looks like a leak for you guys ?
  3. So yes, I'm a victim of a H80i that decided to leak, destroying my Prized x58 motherboard and Xeon 5670 CPU. That's not the worst bit, it toasted my near new $1000 EVGA 1080ti SC2. I've filled in all the RMA forms, submitted them over a week ago and heard absolutely nothing back. When I chase up, they just say "have you emailed the forms?" - erm yes! Anyone been though this and can advise how long it takes? - I Cannot believe the destruction this has wreaked.
×
×
  • Create New...