Jump to content
Corsair Community

Search the Community

Showing results for tags 'keyboard issue'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • English Support
  • PRODUCT DISCUSSIONS
    • CORSAIR Software
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Location


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 15 results

  1. My k70 lux red keys(WASD shift) are fading away can someone tell me where can i find some replacements?
  2. Bought corsair k70 low profile mounth ago, After a while, I noticed that once a day, one double click could work on any key. I checked in the program switch hitter and double clicks really work on a random key if you press a lot of times by pressing all the buttons very fast within 3-5 minutes (by putting two palms on most of the buttons). What can I do to fix this problem?
  3. I don't know if this is an ICUE problem or I hit a combination of keys to make this happen, but I need someone's help. I just got the strafe RGB MK.2 not too long ago, this is my first Corsair keyboard and I'm loving it. Unfornotally I'm running into my first issue nothing extreme, but no idea what I did or how I did it. I was cleaning my keyboard put all the keys back together and that's when I noticed I couldn't remap my keys anymore. I personally like remapping CAPS-lock to Ctrl for gaming reason and since the cleaning, I just can't. Also noticed the three-button above the F1 through 4 keys stop working. I'm amusing what is the profile button, the lighting button and the window lock key for in-game. Before I clean the keyboard all three keys worked perfectly fine, now none of them light up with the rest of the keyboard and two of them are stuck solid red. I'm thinking I must have hit some combination of keys while I was taking the keys off, I was being stupid an doing it with my pc on. Can anyone help me fix this problem or has any experience with a problem like this? Thanks for any help. (EDIT) okay, I guess those three buttons above the F1 row don't light up with the rest of the keyboard, but they don't work anymore. Can't lock the window key and I can't change the brightness of the backlighting on the keyboard. I don't know if profile button works i don't have any profiles, I've been using default.
  4. So my: S, 4 & . Keys are not changing to most colours, they all different. 4, only red s, yellow, orange & green ., blue & green i spoke with corsair a while ago who got me to try multiple software re installs and updates, and a rest with the button under one of the stands. Today just before writing i replaced the actual switches on the board and it is still doing the same thing so now I'm confused and don't know what to try. The picture attached is after i replaced the switches & static white backlight https://imgur.com/a/0DyBH7f
  5. Hello everybody, I just bought my keyboard (K70 LUX RGB) from amazon and when it arrived today some keycaps were out. I put them all in the right place but apparently there are a few (the arrows and the dot) that when I use them it gets almost inmediately out again (not even pressing hard or anything) I've tried pressing them a bit to see if it would hold into the keyboard but nothing. I assume this is not how it should work or is there anything I can do to tight them and make them hold into the keboard while using normally? If this is somehow an unexpected behaviour, please let me know so I can return the keyboard and ask for a replacement. Another thing, how can I make my keboard have different colors? Do I need to download a program? Because so far it only gets RED and withing the "light" buttom, it gets only darker or lighter but doesn't change to any color. Thanks in advance.
  6. I have recently been having an issue with my Strafe RGB keyboard where if I type to quickly or try to double-tap a key it will miss the second keystroke as if I didn't press it. At no point have I spilled anything on the keyboard, I've made sure all my drivers are up to date through ICUE, and it's not just happening on some keys its all of them! As you can imagine this makes typing enough of a pain but makes gaming difficult at best. Please, someone help me out!
  7. Hey guys, I bought the k95 rgb platinum on primeday on amazon. I got it delivered today and everything is working fine expect the key "d". The RGB is working fine even on this key but when i click it, its not working. Now my question is, do i have to do some software uptade or maybe the key is not even set ? If so where do i have to go to look it up ? Or maybe some other tips ? Because i feel like i have to send it back and get a new one. thanks in advance
  8. Hi everyone, I have been encountering this issue with my K55 keyboard and do not know how to fix it, as I don't know what causes it. For some reason,certain keys on my keyboard stop working and do not register input, but I bought the keyboard brand new. The macro button, and window lock button do not work, as well as my control, tilde, numbers 5 and 6, insert, home, page up, delete, and Certain f keys do not work. I have already tried uninstalling and resetting the drivers as well as updating the firmware via iCue. At this point, i have no idea what to do as I'm at a loss. That being said, i had this problem before but it resolved on its own, when I accidentally touched one of the macro keys. Anyone have any clue as to what's going on? Thanks, RawrItsRobert
  9. Here's the situation: Some of the lights weren't displaying the correct colours on my keyboard, and so I decided to contact Corsair support as they got more serious. I sent and received support tickets, following their instructions to hard reset my keyboard. Before hard resetting, the only problems were the incorrect colours showing. However, after hard resetting, the keyboard refused to work completely on my laptop (which I normally use it on) and another PC. The lights would not turn on at all and none of the keys would work. After reporting that on a ticket, they told me to update my BIOS and drivers and reset the keyboard a different way, which I did only to no avail. After telling them that my keyboard still wasn't working, they approved an RMA and asked me to send my keyboard over to their shipping address. Problem was, I live in Australia, and sending something over all the way to Taiwan (where their warehouse is located) isn't as cheap as you think. It put me off how I had to pay the shipping fee because technically they were the ones who told me to hard reset my keyboard, which lead to the keyboard ceasing to work. Since it wasn't really my fault, I don't see how it's fair to charge me for a problem they caused. They said it was my responsibility to pay for the shipping due to their customer policy (which I can't seem to find anywhere online). I'm not saying this is entirely their fault and that I did nothing wrong. I just want your opinions and help on this matter.
  10. Dear Support team, A week or 2 ago we had to disconnect the electricity and when i turned the electricity back on the keyboard wanst connected anymore. I did had that issue once befour but that time i was able to connect the device again and now it doesnt. when i connect it a map opens with a file called firmware but i cant do anything with that. I hope you have a solution for me.
  11. Hi I have an Asrock H61M/U3S3 motherboard, and I cannot get into its UEFI or even select the boot menu with my Corsair K55 keyboard. I read that the K70 and K95 models had a similar issue but that was a few years ago that those threads were written/posted into, is there anything I can do to allow the motherboard to detect it in the UEFI/BIOS? Is this still an issue? How can a keyboard not be usable for getting into the UEFI/BIOS? I have Legacy USB enabled in the UEFI, and I know that USB keyboards can be detected because I have already tried and can successfully access the UEFI with an extra USB keyboard I have here at home. I have already tried plugging into every single USB2.0 port.
  12. My replacement K95 keyboard has a fault with the "F" key... For example when the F key is: Set to "white" it is displaying as "yellow" Set to "pink" it is displaying as "red" Set to "blue" it is displaying as "green" Is there anyway to fix this? I have tried flashing the firmware, and doing a clean install of CU2. http://imgur.com/a/KIBS6
  13. Hello, I recently purchased the Corsair Strafe. I downloaded the proper software from corsair but it shows no device connected. It reads my mouse which is the M65 RGB Pro and am able to edit the color scheme on it. The keyboard however wont appear. I tried different USB slots, keyboard reset on the back. I'm out of ideas and help is appreciated! Thanks!
  14. Hello, A new issue with my K30 appeared since a few days: Each time I reboot my PC, the K30 lose its special functionalities: Programmable keys are not working anymore When launching the config utility, the luminosity and pulse led options have no effect What I have to do each time is to reinstall the K30 software, and then it works again. The issue seems new because K30 was working ok before the last Windows 10 update. Any idea what I should do to fix this? Thanks.
  15. Hey guys, I'm super new to this forum, and this keyboard (at this moment in time it has been unboxed and in use for maybe an hour lol) and I have a query that nobody seems to have answered online (maybe they have and I'm an idiot... 100% possible). Basically, I've created two profiles, and they work when the computer is actually in use. However, as soon as I go to lock the computer with windows key and L, the keyboard almost reverts back to the out-of-box presets, and I don't know how to fix this in CUE2. Any advice, experts??:laughing:
×
×
  • Create New...