Jump to content
Corsair Community

Search the Community

Showing results for tags 'k95rgb'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 2 results

  1. Just got my new K95 RGB Platinum. Updated the firmware to v. 3.29.32. Deleted all default profiles and loaded in the ones associated with my Scimitar. I can use Ctrl with X, C, and V for cut, copy, and paste but Ctrl + A is not working. This does not work with the Left Ctrl or the Right Ctrl +A. I have unplugged and replugged my keyboard. I've tried different USB ports on my computer. I've restarted my computer. Any thoughts or solutions?
  2. Hello, When I try to update the firmware of my K95 RGB Platinum to 3.29 (from 3.21.28) it's fail immediately: My keyboard disappears from my iCUE (latest version 4.13.226) on Windows 10 Pro 64bits till I reboot, or I switch from the K95 Software mode to BIOS mode and Software mode again (with Windows Lock+F1 x2) to see back my keyboard into iCUE. But the firmware update fail and request me to update it again and again... Could you help me please ? PS. For information, I'm French and I use an AZERTY layout keyboard. We can continue to speak in English into this thread.
×
×
  • Create New...