Jump to content
Corsair Community

Search the Community

Showing results for tags 'k70 rgb issue'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 3 results

  1. So I just got a brand new K70 for christmas and I was really excited to customize it but it doesn't work with ICUE. I have a corsair void headset and ICUE can detect it and can customize it but it doesn't detect the keyboard. I can still type with it but it isn't able to be customized. Also the scroll lock key flashes and switching it to the 1,2,4,8 doesn't work so I have to keep it in BIOS mode. Switching it to any of the other ones doesn't work and the keyboard's lights just turn off and I can't use the keyboard at all. The windows lock key and volume buttons don't work either. I would love to get a fix for this problem as soon as possible. This has been really frustrating so I really want to get a fix for this soon.
  2. Hello, I have a K70 LUX RGB that was working perfectly fine until about 4 months ago. It would disconnect, and I would need to soft reset it to get it working again. Now, it wont even turn on. The pass through still works, so I do not think that it is the USB's problem. I have tried Soft and Hard resetting it, still nothing. I have tried the different frequencies, restarting my computer, and still nothing. What am I supposed to do? I spent a lot of money on this keyboard for it to only last me 1 and a half years. Thanks
  3. So I've provided attachments that show my CUE colour layout (being all orange) but on my actual keyboard it shows different colours on some of the keys, when i put it into a Rainbow Wave lighting effect, these specific keycaps dont sync with the other keycaps; they all go different colours. Keys : F1, 1, S, Z, and Alt key are blue F9, 9, L, < , Left arrow , Numpad 3 are green Backspace, Scroll Lock, Pause button for music, 9 are a faded / light blue O is just all red Is there any fix to this? It used to be just the O that had an LED problem but more and more keys are starting to break and it doesn't look very appealing anymore. I've had this keyboard for about a year or two now. First post, sorry if i missed out on important information and such. Any help would be appreciated,Thanks
×
×
  • Create New...