Jump to content
Corsair Community

Search the Community

Showing results for tags 'k70 freeze'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • iCUE

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 2 results

  1. Hi everyone, I have this problem with my Corsair keyboard, it happens randomly. When I use the volume control on the keyboard it stops working and it's like if the control is stuck on zero volume, or sometimes it happens the opposite, the volume keeps going to 100 and keyboard stops working. In Icue there's a red triangle on the keyboard, the only way to fix this is to unplug the usb cable and connect it again. I made a video of the problem: https://streamable.com/623bvm I want to know what's the problem: the motherboard or the keyboard? Thanks to everyone for the help! :biggrin:
  2. Hello all. I received this keyboard as a gift recently for my birthday and i have had it from the time of making this post for no more than 3 days, and in those 3 days i have had more issues with this keyboard than i ever have with my K66 (never had one by the way). I did some minor research and it seems like this keyboard is prone to issues and some people have even had the same problems that i am having currently. To begin with when i received this keyboard and first plugged it in to my USB 3.0 port on my pc is gave me the following error (https://gyazo.com/cfd531c488acb7dd5de6a0e38bace320). This was my first issue however this seems to have dissipated by itself (not 100% sure). After hopefully solving this issue my next issue is that whenever i plug the keyboard into multiple ports being 2.0 and 3.0 it does 1 of 2 things every time. The first option it does it light up, the RGB turns on and copys the default rainbow spiral pattern that it comes with for about 3 seconds and then stops and freezes on whatever the pattern was on, the keyboard then looses all functionality in typing and media keys, everything is frozen. I then get a red exclamation point encased inside a red triangle as well in the iCUE software on the bottom right hand corner of the keyboard logo. The second option is that whenever i plug it into the port it does nothing, it does not light up, does not function, nothing. It's like no power is going to it. (Sometimes the profile and brightness keys light up) but that is about it for the second option. I can sometimes get it to work for about a minute to two minutes but then it reverts back to option one and completely freezes on me. I've searched vigorously across Youtube, Corsair forums and the internet. Every solution or recommendation people have said i have done, changed my USB Media settings to false, re installed the iCUE software updated everything on my computer and nothing still works. The only thing that gets me close to it being fixed is uninstalling the iCUE software which makes me thing its either something to do with the driver that the software is installing to my pc or its the keyboard drivers itself, i could be wrong i am no expert. When i have the software uninstalled the keyboard works for 3/4 minutes then reverts back to the option one i stated earlier. I have contacted the support and made a ticket and they told me to do the following: Please follow the directions below: 1: Unplug your keyboard from the computer. 2: Locate the small pinhole underneath your keyboard. For some, this will be located near the polling rate switch by the cable. On others, it will be located underneath on the tilt legs on the bottom of the keyboard. 3: Using a small paperclip or push-pin, press down on the button inside the pinhole. 4: Plug your mouse back into the computer, while holding down the pinhole button. 5: Once it is plugged back in, your computer should recognize a drive called CRP_Disabled. Please open this. 6: Download the firmware file from the ticket. If it is compressed into a .RAR file, please extract this file to an easily found location on the computer. 7: Delete the file FIRMWARE.BIN from the CRP_DISABLED drive, and then place the file with ISP in it’s name to the CRP_Disabled drive. 8: Once you have performed the steps above, please unplug your keyboard and then plug it back in. The device will then return to normal. Please test to see if the issue reappears. If it does, please inform us on the ticket for further troubleshooting. I have followed this step by step but whenever i plug the keyboard into my PC there is no pop up what so ever that comes up with the CRP_DISABLED drive. So i can not test or try this solution. If anybody knows a way i could navigate to it manually i would appreciate it. Now corsair support being what it is i really do not have the time or patience to wait 3 days at a time for a small reply. I paid $100 for this keyboard and i would like to return it if i can not get a fix so as you can imagine my time in returning it is running out. I really don't want to send it back as i love this keyboard and corsair is defiantly one of my favourite keyboard producers however i do not want a dysfunctional keyboard so if anybody has any suggestions at all id be forever grateful. Thanks for reading, Trikz.
×
×
  • Create New...