Jump to content
Corsair Community

Search the Community

Showing results for tags 'jack'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Location


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 3 results

  1. Hola primero que nada los audifonos funcionan bien, los probe en mi celular (ya que son entrada tipo jack 3.5mm) y el microfono como el audio se escucha bien. Pero al conectarlos a la pc no reconoce el microfono y el software de iCUE tampoco los reconoce. Me asegure de que estuvieran conectados correctamente y de que el adaptador en (y) tambien lo hiciera y todo bien. Incluse probe con otros audifonos que tengo y todo funciona. Mis audifonos solo vienieron con los audifonos el adaptador en (y) y un pop out pequeño. He visto que normalmente vienen con un adaptador 7.1 de jack a usb pero los mios no venian con eso. Hay alguna manera de hacerlos funcionar como deberian sin eso? Adjunto el link donde los compre https://www.amazon.com.mx/gp/product/B08L72D1DV/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
  2. I just bought the standard Virtuoso. The audio cable seems not to work at all! It doesn't work with the Virtuoso and it doesn't work with my previous logitech G633 headset. In addition the jack on the Virtuoso seems messed up. The cable doesn't insert all the way, it's not flush with the headset, i.e. you can still see silver on the jack. The jack also makes a scratchy noise while inserting it, which sounds wrong. If I try another audio cable with the headset it can work but the sound is very messed up. The voice sounds warbled and it sounds like the singer's voice is in the background. Hoping you can help because we've spent a lot of money importing this headset from the UK (I'm based in Kenya). It's not easy or cost effective for me to return it.
  3. Hello, I broke the connector jack, how can I replace this? Where do I buy the same jack to replace the broken one?
×
×
  • Create New...