Jump to content
Corsair Community

Search the Community

Showing results for tags 'hs50 pro'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • iCUE

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 1 result

  1. I just received my new Corsair HS50 Pro Headset. While the sound works fine.. The mic does not record my voice in either state of the headset mute button. My older headset works properly with no problems. My cheap clip-on microfone also works fine. The headset is properly connected with the y-Splitter. The microphone is clipped into the headset. When listening to audio through the headset the mic is able to record that. It works in both mute states. It even works without the mic being attached to the headset. It wont record the audio when the 3.5mm mic jack is not connected to the computer (obv). So i believe its not my computer's fault. In following thread the phenomen is described as "sidetone audio through the earcups" [https://forum.corsair.com/forums/showthread.php?t=1774989]. The steps described did not fix my problem. Im running Win10 Version 20H2 (OS Build 19042.508). I will need the headset working properly for an online job interview next week. Maybe the problem can be fixed easily due to user error. Otherwise i will have to send it back. With best regards, User23112020
×
×
  • Create New...