Jump to content

Search the Community

Showing results for tags 'h150i vs'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • iCUE

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 1 result

  1. mr_scary

    H150i vs H110

    I recently purchased an H150i Pro, Installed it on a 5930K Stock CPU Temps were much higher then my 4+ year old H110. Both coolers were mounted on the top of a 760T as Push/Exhaust. H150i | Idle-33°c | Max-51°c | Ambient-71°F H110 | Idle-28°c | Max-38°c | Ambient-71°F I tried mounting the H150i twice. Tried first without iCUE software Second remount with iCUE software 100% fan. Second time with the same TIM I always use. However I could not find any pump RPM setting it was always grayed out. I know these temps are not terrible but, the performance gap is huge IMO. However my entire system was warmer, Ram, VRM, even the plastic RGB Corsair logo was very warm to the touch 89°-90°F measured with a laser thermometer. 82°F with the H110 installed. I ended up returning the 150i, Corsair's excellent RMA service replaced my failing fans on the H110 so I have it back in the system working perfectly. Some people seem to think this was a faulty pump or something. I've remounted the H110 probably 6 times in total on this PC for cleaning over the past 4+ years. twice in past couple weeks, and the temps are always the same. Is the 280MM radiator supposed to perform that much better? Possibly larger copper block? I will keep this H110 forever.
×
×
  • Create New...