Jump to content
Corsair Community

Search the Community

Showing results for tags 'frozen'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 2 results

  1. I hope someone out there in Corsairland can help me. I have the K70 RGB Lux. All was working fine until the other day when my keyboard was acting as if I was pressing several keys at the same time. Using a keyboard tester, the keys are: F11 F12 Enter, print screen, insert, home and # and ]. I have tried various fixes but nothing has fixed it. I have Removed the keys to clean it Plugged in different USB Changed bios Soft reset (ESC key for 5 seconds) Turned lighting on and off Nothing seems to have fixed it so I am back to my old keyboard. :bigeyes::bigeyes: Would anyone have any advice? Thanks! SpaceMoo.
  2. Hello everyone, I purchased a K95 Platinum Keyboard or Dec. 27. In the 4 days that i have had, its been a complete nightmare. After installing iCUE, i have had nothing but problems. When opening the iCUE window half the time it wont open causing me to have to quit the program and try to relaunch it. If I am able to get the window to open it runs extremely sluggish and 95 percent of the time it says (Not responding) and will then give me the option to wait for iCUE to respond or close the program. I have uninstalled iCUE and reinstalled it at least a dozen times and the problem never changes. Really love the keyboard and don't want to have to switch to another brand, but this software is complete trash and making it so I cant use the macro buttons, which is entire reason I switched to it. I'd appreciate any advice to fix this situation, instead of having to return this keyboard.
×
×
  • Create New...