Jump to content

Search the Community

Showing results for tags 'firmware fail'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 10 results

  1. My Corsair Virtuoso SE Gunmetal and dongle wont Upgrade Always Update Fail I'm following all the instructions and it dosent work. PLEASE HELP ME
  2. Recently I had an issue with my K70 RGB MK.2 keyboard and reached out to corsair support where they then instructed me to reinstall the firmware and provided me with a bin file. I followed their instructions exactly but now my keyboard won't power on and isn't detected. Reviewing the file name of their provided .bin file closer, I believe I was sent the firmware of the wrong model even though I provided my P/N and S/N as it was required when creating the ticket. Looking through old forum posts of users having the same problem, corsair staff stated installing the wrong firmware can brick your keyboard permanently. Now I'm worried my keyboard is now perma bricked and I'm at a loss of what to do since I use the keyboard & configured macros for my job. Anyone have any ideas of how to fix this?
  3. Bonjour, Lorsque j'essaie de mettre à jour le firmware de mon clavier K95 RGB Platinum à la dernière version 3.29 (depuis la version 3.21.28), cela échoue immédiatement (en 1 seconde même pas après avoir cliqué sur "compris") : Mon clavier disparaît du logiciel iCUE (dernière version 4.14.179) sur Windows 10 Pro 64bits jusqu'à ce que je redémarre l'ordinateur, ou que je passe le clavier du mode logiciel au mode BIOS, puis du mode BIOS au mode logiciel à nouveau (avec Windows Lock + F1, x2) pour revoir mon clavier dans iCUE. iCUE me signale alors qu'il y a une mise à jour, encore et encore... Pourriez-vous m'aider s'il vous plait ?
  4. It obviously has flaws. SERIOUS flaws. It turn your left click into a double click with no way of disabling it. And the solution is usually to ask for an RMA. Just let us downgrade the firmware back to 3.11 in Icue and save the headaches.
  5. Hello, When I try to update the firmware of my K95 RGB Platinum to 3.29 (from 3.21.28) it's fail immediately: My keyboard disappears from my iCUE (latest version 4.13.226) on Windows 10 Pro 64bits till I reboot, or I switch from the K95 Software mode to BIOS mode and Software mode again (with Windows Lock+F1 x2) to see back my keyboard into iCUE. But the firmware update fail and request me to update it again and again... Could you help me please ? PS. For information, I'm French and I use an AZERTY layout keyboard. We can continue to speak in English into this thread.
  6. Hey guys, Does any one of you have a firmware file for the Scimitar RGB Pro ELITE mouse? I tried to update it and it failed and everything turned off an its not working. It shows up in my computer as "CRP DISABLD". Already tried the soft reset (left + right click then plug) but it doesnt work. I already opened a ticket but it's going to take forever for them to reply ... If anyonefrom Corsair sees this, could you please help me out? Here's my ticket number 2003839517 Thanks!
  7. Hello, I've had my K55 for nearly 3 years now, cleaned it every few months and generally have had a great experience with it. Yesterday iCUE prompted a firmware update (30.8) and since that update the keyboard has been nearly unusable. As of now a multitude of keys are either unresponsive or acting as multiple keys (e.g pressing the number 4 key with result with "54" been typed simultaneously, ctrl acts as a brightness control key for the keyboard lighting, tilde and 1 will when individually pressed both input `1 together as one input) I don't have much money to spend on another keyboard of similear value however I'm running my very old el cheapo keyboard backup. - I have: Replugged and held FN+F4 for 10 seconds then did an iCUE update - Deleted the corsair composite driver in Device Manager, replugged the keyboard whilst holding Page Up + Page Down to fully reset the firmware and update it through iCUE (When replugging the keyboard with said keys held, the 4 indication lights in the top right corner will flash together in sync and all backround key lights are off.) - Plugging the keyboard into a USB Type 2 port then updating firmware, vice versa with USB Type 3 When updating the firmware the update percentage would sit at 100%, I let it sit for atleast an hour for each method yet it has not finished and I'm unsure of what to do about it. My iCUE version is 3.34.170 I've found no alternatives to fixing this, help is greately appreciated.
  8. I attempted a hard reset of my keyboard with a firmware I found online and I'm able to get the keyboard in an operable state where the num lock, caps lock, and other light indicators are blinking. When I try to update the firmware through iCUE, the firmware gets to 100%, then makes the Windows peripheral disconnect sound, and stays stuck at 100%. I tried this with different versions of CUE and iCUE, and it all did the same thing. I even tried using a firmware image I found online for the iCUE app , and I get the error: "the file you selected is not a valid firmware". I tried this all on different polling rates and USB ports, and none of it works. Can anyone help me?
  9. So this has me stumped. I have a Corsair Glaive that was on 1.03, CUE 2.23.40 reported a firmware update. When running the update it failed @ 0% and the mouse would disappear from CUE. Closing and reopening CUE brought it back. I contacted support who had me soft reset the Glaive. Then place the mouse into bootloader mode and copy 1.03 across manually and reattempt the firmware update. This didn't work either. My friend dropped by with her PC, running CUE 2.15.83. The mouse updated to 1.04 no problems! So seems the issue might be my PC. My PC is a 8700K, MSI Z370 Gaming 5, Win 10 with a Corsair K95 Platinum also connected. The keyboard updates no problems. Just the mouse would not. Anyone come across something like this before? I also tried disabling USB legacy mode Disconnecting all other USB devices I didn't try disabling XHCI as I believe Skylake and up needs this enabled for USB to work at all. I also haven't tried disabling MSI fast boot, as that only affects USB devices during boot. Other than the firmware issue, the mouse works fine. I just don't want to have a problem, down the track where a firmware update is the fix.
  10. I have an update notification that shows a firmware update is available for the Scimitar to 2.04. I tried running it but it immediately fails. I thought it might be due to the version of Cue 2 that I was running, so I updated to the latest 2.6.70 but it fails there as well. I've also tried running Cue 2 in administrator mode but no change. Currently running Windows 10 Pro 64 bit, mouse is connected to a USB 3.0 port. Any ideas?
×
×
  • Create New...