Jump to content

Search the Community

Showing results for tags 'electrical'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 2 results

  1. I recently custom built my pc and it was working fibe for months. However, it has now started to turn off my house electrics randomly when is on standby. I got the power supply replaced yesterday as I thought it might be the psu thats tge issue as when I plugged it in on its own it turned my electrics off. However, after only a few days it started doing it again. Could it be an issue with one of the fans or a faulty socket?
  2. Hello, I know there have been threads about this issue but I wanted confirmation... My PSU has been waking this weird noise for a couple of days. It happens mostly after gaming, not so much at idle. I recorded it : [ame] [/ame] Can anyone please confirm what this is and what I should do about it please ? Thanks:biggrin:
×
×
  • Create New...