Jump to content
Corsair Community

Search the Community

Showing results for tags 'corsair scimitar'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 3 results

  1. No idea how to start this but whatever here it goes. I don't know if its iCue or the mouse itself, but everytime I plug it in and open the iCue software it turns mouse acceleration on, I double check if it's actually in my windows settings or in the software settings but it's always off in both. Now here's the even more annoying thing, I have logitech mouse aswell that I use for shooters etc. and after having iCue open and the the Corsair mouse plugged in my logitech mouse ALSO has mouse acceleration turned on. Closing the program and unplugging the corsair mouse doesn't help and I have to restart my computer with the mouse unplugged and the program closed to make the mouse acceleration go away. I made sure to close other programs that could conflict with iCue but that didn't help. In short, I will send this mouse back if there is no way to turn off this horrible automatic mouse accel that applies to all devices somehow. No it isn't just a feeling I measured the travel distance before anyone thinks about commenting on that.
  2. I had recently purchased a manufacturer refurbished Scimitar Pro on eBay and right out of the package and plugged in I noticed there was no press down on the scroll wheel. The mouse wheel just stayed still with no tactile feedback. The only way a mouse wheel click does happen is once an hour while scrolling down where the wheel suddenly feels like it snags onto something and and then inputs a middle click. Wondering if there is any way to fix this issue or I should just ask the seller for a return. Thank you.
  3. When I am using the mouse it will stutter then switch color schemes. It will be a sky blue and then suddenly change to green, purple and dark blue. Sometimes when this happens my macro's and keybinds will stop working. It's a fairly new mouse had it for a month or two but this issue keep persisting. I have turned off SDK and tried different profiles but non will fix it. I will attach the logs.Morelogs.zip
×
×
  • Create New...