Jump to content
Corsair Community

Search the Community

Showing results for tags 'broken?'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 3 results

  1. Hey ich habe gestern meine h115i elite capellix bekommen eingebaut sie Leuchtet und kurz nach dem Start fängt die aio und die lüfter an rot zu blinken und im BIOS wird die CPU mit 80-100°C+ Angezeigt meistens fährt mein PC sich nach 1-3minuten runter wegen der CPU Temperatur. Danke im Voraus für Hilfe 😄 PC specs: Mainboard Gygabyte X570 AORUS Master und CPU ryzen 7 5800x
  2. Hello, today I bought a nightsword rgb at microcenter. I open the box to use it and it works normal for 1 second then my cursor stops moving. I don't know what else to explain if you have any ideas on how to fix this? Or what else I should do. Thoughts would be appreciated. Thank you for your time. Wholeebear
  3. So recently my microphone had stopped working in the middle of a session with a couple of friends. I've had the headset for 2 months and it seems to have already broken to my knowledge and for no explicable reason. I don't actually know why or how this has happened but when i move the mic around to certain angles it seems to make a slight static and work but if let go from that position it makes the same static and doesn't work. I've checked drivers and plugged it into different USB ports and it has the same problems. I've heard this headset was very durable and one of my friends has had it for 2 years working but the opposite has happened. If anyone maybe knows why or how this happened or what i should and can do that would very much appreciated.
×
×
  • Create New...