Jump to content
Corsair Community

M95 cursor stops every 2-3 minutes


Redspeed93

Recommended Posts

Hi

 

I just got an M95 for christmas, after having used (and worn down) and M60 since the day it was available here in my country. I loved the M60.

 

I don't love the M95. I love it when it works but it doesn't work for more than a few minutes at a time. The problem is that the cursor just stops and micro-stutter in the same place even when I toss the mouse from side to side on the mousepad. It also stutters a tiny bit constanty, meaning when the mouse itself is completely still the cursor still "jumps" a few pixels in different directions :mad:

 

I have no idea what specifically is causing this, but I have ruled out it's not my PC, since the problem persists across 5 different machines, with various different ports on all of them. The cursor has stopped 6 times while writing this short bit of text.

 

Is this a software or a hardware problem?

Link to comment
Share on other sites

I had a problem similar to this when I purchased the mouse. It's been a while but I think it was either due to being plugged in to a USB 3 port instead of USB 2, or it was due to flash or hardware acceleration. Worked through a few issues so I'm not 100% sure, but I think it was due to the USB port. Are you using a USB 3 port?
Link to comment
Share on other sites

I had a problem similar to this when I purchased the mouse. It's been a while but I think it was either due to being plugged in to a USB 3 port instead of USB 2, or it was due to flash or hardware acceleration. Worked through a few issues so I'm not 100% sure, but I think it was due to the USB port. Are you using a USB 3 port?

 

As stated in the first post a bunch of different PC's and port have been tried - this includes both USB 2 and USB 3.

Link to comment
Share on other sites

It sounds like the mouse may be faulty. Request an RMA to replace the mouse.

 

The mouse is just fine. It works well on 2 other laptops I tried today. No problems whatsoever. Smooth, no hiccups and no stuck cursor for serveral seconds.

 

So it has to be drivers/software related.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...