Jump to content
Corsair Community

300R Front USB Stopped Working


Recommended Posts



Yesterday I installed a new Nvidia GTX 760 graphics card in my system and after a bit of messing around, and having to update my BIOS (ASUS Sabertooth 990FX) it worked.


This morning I plugged my iPad into the front USB 3.0 Port, but the computer won't recognize that the iPad is plugged in, it isn't even saying 'Not Charging' as usual. The USB Ports were working yesterday evening, because it was 'charging' the same iPad.


The ports also don't recognize that USB Memory sticks are plugged in.


Any ideas? :)

Link to comment
Share on other sites

Have you tried replugging the USB 3.0 cable?

Check your BIOS and see if USB 3.0 is disabled or a setting is causing the issue.


I tried unplugging the USB Font panel cable from the MB and plugging it back in, and no luck.


I have also looked in the BIOS and can't see anywhere to turn the front USB off.


And the integral USB 3.0 on the back still work.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...