Jump to content
Corsair Community

Corsair Headset Control Panel Unusable


Recommended Posts

I got my hands on a Corsair Vengeance 1500 headset a few days ago and despite a great deal of perseverance, I have been unable to get the control panel software to function as intended. The headset itself is fantastic, I have had no problems with the hardware.


After receiving the headset, I initially installed the "Corsair Headset Software Version 2.0.16" from the downloads area here. The software installed successfully and worked perfectly. After a reboot however, the software no longer worked.


I have reinstalled the software several times, trying versions 2.0.19 (The newer Beta drivers) and the older 2.0.7 release. I have also tried running the control panel as an administrator. The issue persists.


Regardless of the installed version, after the system boots with the headset unplugged, the "Corsair Headset Control Panel" is visible in the system tray, right clicking the icon displays a menu with the disabled options "Restore" and "Information", with "Exit" being available. I assume this is to be expected as the headset is unplugged.


As soon as the headset is plugged in, however, the menu does not display after right clicking and a double click does not restore the control panel interface. A quick look at the task manager also reveals that "HeadsetControlPanel.exe" begins to use a constant 13% of the CPU as soon as the headset is plugged in and continues to do so even if the headset is unplugged.


If at this point, I terminate the process and execute "HeadsetControlPanel.exe" again, one of two things will happen depending depending upon whether or not the headset is plugged in. The application starts as expected if the headset is not plugged in, being visible in the system tray. If the headset is plugged in before starting the software, the outline of the software's GUI is visible as shown here and the application immediately stops responding. It must be closed via the task manager.


My system is running Windows 7 x64. I also have a Corsair Vengeance M90 mouse and as such, its control panel is also running on the system.


Note once again that the software (Version 2.0.16) worked perfectly immediately after installing for the first time and without rebooting. As soon as I rebooted however, the problem materialised.


I haven't came across anyone else with this exact issue, any suggestions would be appreciated, thanks in advance!

Link to comment
Share on other sites



try the 1.1 drivers


also go into your bios and make sure the onboard soundcard is switched off


The 1.1 drivers installed and worked perfectly.


I also noticed that if I:

•Uninstall the existing drivers

•Install the 2.0.16 drivers

•Plug in the headset


The software doesn't crash (Use a constant 13% of the CPU and become unresponsive) until Windows finishes installing its drivers. I'll have to see if preventing Windows from installing its drivers solves the problem. Otherwise, I'll continue to use version 1.1 of the drivers.




Edit: I forgot to mention that I also have a Corsair Vengeance M90 mouse and as such, the control panel for that mouse is also running.


Edit: I've since tried the headset on another Windows 7 (x64) system in the house, a relatively outdated Socket LGA 775 system, the headset drivers (2.0.16) installed and worked fine, persisting after a reboot.


I'll be tempted to format this system to remove any potentially conflicting software. I've also tried the headset in USB 3.0 and 2.0 ports on this system, the problem is apparent with both.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...