Jump to content
Corsair Community

Got Link Software and Hardware Fixed (Commander/AX1200i/H100i/Cooling Node)


Recommended Posts

Hello all,


I have been in the same boat as most of the other dissatisfied patrons of the corsair link product line... actually, I think my situation may have been worse, as my installation of the commander and cooling node caused my bios to stop detecting my cpu fan!!! (of course the h100i was actually working, just not being detected by bios). Anyway, I am running Windows 8.1 on and ASUS RIVE Black Edition with a i7 4930k cpu. I have 32GB of Dominator Platinum RAM installed, and my system is mildly overclocked at a cpu frequency of 4500MHz and RAM requency of 2133MHz. -- probably not required info but included just in case.


My system would boot if I ignored the cpu fan detection warning in the bios, but the link software detected NOTHING... I tried every combination I could think of. I connected the everything to the commander directly, with only the commander's usb connected to the MB. I tried connecting all three devices (the H100i/AX100i/Commander (Cooling Node does not have a USB)) to the MB. Nothing worked. Here is what I did to get mine working.


Note: This fix worked for me, so I'm not making any promises.


I hooked all of my products up the way that they should ideally: each connected to the Commander, which is then connected via USB to the MB header.


I followed the registry fix suggested by others in the forum to address the USB selective suspend issue in Windows 8.1


"Goto HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Enum > USB > VID_1B1C&PID_0C04 (and _OCOO)> 5&28a8b183&0&2 > Device Parameters >


Change All REG_DWORD to Value 0




Restart PC"


Because I had previously updated my H100i to FW revision 1.0.7, I did not need to flash it; however, I was using the FW the the other devices shipped with (Commander and Cooling Node). However; how was I going to get the FW updated if the link software would not detect the devices? Here's how.


After performing the aforementioned steps, download the following FW and SW versions: Link 2.1.1; Commander 2.0.6; Link Cooling FW 1.2.5 (I tried attaching the files but is wouldn't let me for some reason).


Now install Link 2.1.1.


When it loads, it will not be clear that it has detected the Commander, but it has... in other words, no devices will show up.


Go to Options -- Devices, then click update firmware.


A dialog will open saying that the Link software would be closed in order for the FW updater to run. Click ok or accept or whatever.


When the FW updater opens, the device to update will be the Commander (it will be greyed out, as no other devices are detected until this one is updated).


Direct it to the Commander FW file 2.0.6s19 and click start. Once the firmware is flashed, reopen the link software.


You should now see the Cooling Node under devices, but none of your fans or temp sensors will show up yet. Again go to Options -- Devices, then click on the Update Firmware button again.


This time the device to be updated will be selected via a dropdown list. Choose your Corsair Cooling Node. Direct it to the file CorsairLinkCoolingFW_1.2.5.s19 and click start.


Once it finishes restart the Link software and you should see devices beginning to show up (i.e. fans, sensors, etc...); however, the names will be incorrect and they will be uncontrollable for the most part.


Now close the link software, stop any related processes via the task manager, and then uninstall the software. Now delete all traces of the software by going into program files (x86 for some) and then deleting the Corsair folder. Go to C:\program data (this is a hidden folder) and delete the Corsair folder there. Finally, go to C:\Users\(your account)\app data (also hidden folder) and check in both local and roaming folders for and Corsair Link remnants.


Now shut the computer down, and disconnect its power (or flip your PSU's switch to off).


Unplug the H100i's cpu fan and reseat it on the MB header (this step is something I did as a precautionary measure and may not be necessary).


Now power on and boot up. Go online and download the latest version of the link software. (I just went to product page downloads section and downloaded from the main site)


Install Link software and -- if it worked -- jump up ten feet in the air and yell f*** yeah! All of your devices should now show up and be manageable.


I've attached a screenshot of my functional Link software.


I hope that this works for everyone else, and I would like to give a big thanks for nothing to Corsairs support department. I build computers as a hobby on the side... why am I able to solve that which you could not? Pathetic!


Carson Riess


Link to comment
Share on other sites

I hope that this works for everyone else, and I would like to give a big thanks for nothing to Corsairs support department. I build computers as a hobby on the side... why am I able to solve that which you could not? Pathetic!


the reason for this is actually very simple.

computers and included components /software are like ones fingerprints-their each unique and thus this is the dilemma Corsair has to deal with.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...