Jump to content
Corsair Community

Just information - failed Corsair H80 observation


Recommended Posts

Hi all,


Well after 2 years of an erratically behaving H80, with random max fan speeds and so on, the Commander finally (and partly) died. It no longer controls the cooling fan attached to the radiator, the link node is also dead, but interestingly the pump still works. My pleasant observation is that for normal/slightly hard use where temps don't get that high (over 60C), just the pump alone is keeping the CPU cool (around 40C) when lightly used.


Despite this, I went for the 'better the devil you know' option and have bought an H80i. I haven't fitted it yet though, as I'm quite liking the near silence coming from under the desk!


Just for reference, here's my cooling spec:


Case: Thermaltake Armor (yes, very old)

PSU: Thermaltake Toughpower 750W

Graphics: GeForce GTX 560 Ti (rear fan vent)


Side: 250mm, sucking in

Front: 120mm sucking in and over 4 HDD & 1 SSD

Top: 120mm blowing out


Comments welcome!

Link to comment
Share on other sites

Ah, slight error (I was tired when I wrote), the commander unit itself didn't die, just the link.

So you are right, the fan controller died. The fans work when plugged in independently to a power source.

Not sure about the link, it was working, then I unplugged it and tried a different set up, when I plugged it all back in as it was, it no longer worked.

Link to comment
Share on other sites

The H80 has a 5 year warranty. You can request an RMA to replace the cooler. Make sure you have the receipt handy as they may ask for it.


As for the Commander unit, do you mean it's no longer detected in the software?

Go to Devices and Printers and see if you can find PMBus Bridge under Unspecified.

Link to comment
Share on other sites

That is incredibly useful information Toasted, I'll pull it out and get an RMA going. I placed one for the Link unit about a week ago, but haven't heard anything yet(?). I'll definitely have the receipt, I'm a stickler for that!


The Commander unit seems fine, it's just the link unit which isn't controlling the fan, neither case fans or CPU fan - but the pump is working. I've left it in place with just the pump working because it's surprisingly staying cool, provided I don't stress the machine too much.


Really appreciate your help friend.

Link to comment
Share on other sites

Did the Cooling node work before?

Have you tried the latest software?

Is the Cooling Node on the latest FW?

Yes - for around 18months.


It was up to date, but this problem occurred when I went to load the new latest version, directly downloaded from the corsair website.



Link to comment
Share on other sites

Ah interesting, my lightning node was killed by the latest update too. Not sure what to do now though as it wont let me do anything with it. I cant update its firmware no matter what version of link I try

Sorry to read that. I know something strange is happening with my old H80 and someone mentioned it has a 5 year warranty so I'm doing an RMA at some point. My point is (I get to it eventually), I wonder if the Link Node whether normal or lighting has a similar length warranty?


I put in an RMA nearly two weeks ago, and have heard nothing at all from Corsair.


Is the Cooling Node detected normally?


If yes, reflash the firmware and see if that helps.


The problem is, after the failed firmware install, the node is no longer detected within the Link software :(

Link to comment
Share on other sites

The Cooling Node is discontinued, so you may not be able to get a replacement.


What you can try is to reflash the firmware with an early LINK v2 release as it does not have any firmware protection.


Unplug all your working LINK nodes expect the Cooling node from the Commander unit as well as uninstall the current version of the software.


Download a really old LINK v2 release e.g. 2.1.1 and install it. Make sure the Commander unit is detected, when it is, open the firmware updater and in the drop-down menu select "Unidentified Node" and browse to the correct FW for the Cooling Node, try the update. Did it reflash successfully?

Link to comment
Share on other sites

Hmm, sounds like Corsair don't have confidence in their own product if they discontinue it. It's such a shame when large companies treat potentially useful hardware as hobbies that they can drop at a moments notice.


Sadly I did try installing older versions of the Link software, down to 1.2.7. and it didn't work. The main thing is that the CPU fan is working and is controllable, so it's OK for now. I'll probably opt for another solution to control the other case fans (of which there's only two), if you have any suggestions, I'd be very keen to here them.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...