Jump to content
Corsair Community

Flash Voyager Mini USB 2.0 16GB - Stopped working.


MrFodds

Recommended Posts

About a year ago I purchased a Flash Voyager Mini from Ebuyer, and it has served me well up until recently. Yesterday I plugged it in to upload some files, and I got the Windows "Scan and Fix" message. I have heard of the horror stories about it, and up until that point had always click "Continue without scanning." But for some reason I clicked "Scan and Fix" and thought nothing more of it until today I came to use my Flash drive and it no longer works. I have tried uninstalling drivers, devices and every other fix a Google search threw up and none of them have worked.

I have also tried the flash drives on all other computers in the house and no luck.

Has anyone got any help, keeping in mind I have some very important data on it relating to work and would prefer to get it working.

-Thanks in advance, Ben.

Link to comment
Share on other sites

Other than possibly reformatting it there isn't much you can do with them other than to have it replaced. And there are no guarantees that a reformat would work either.

Your data would get wiped in the process though. And if it's completely dead them the data would not be able to be accessed anyway.

 

Please use the link to the left to request an RMA.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...