Jump to content
Corsair Community

H80i randomly stopped working, now its not recognized :(


Recommended Posts

I noticed this close to a week ago. I sent in a support ticket that was supposed to be responded to within a business day but still nothing. Tried live chat and no one was available.. Hoping to get a work around here.


Specs - i7 3770k | asrock z77 extreme 4 | H80i | GS 600 power | Radeon HD 6900 series | 16 GB RAM | etc etc


It was working fine, pretty sure I hadn't updated it or anything like that. Now the fans won't spin, the hardware isn't recognized and the LED doesn't light up.


I uninstalled (including dongle), deleted profiles, cleaned my registry with CCleaner. Tried updating to newest version. Still nothing.


Deleted unrecognized hardware in device manager, and upon restart unrecognized hardware it back.


It should be noted, after waking PC from sleep it has started and was working fine twice. After putting PC back to sleep or restarting, back to 0 recognition.


If anyone has any ideas, would be great to hear :(

Link to comment
Share on other sites

when you put your computer in sleep mode the link software will stop monitoring and will need a restart,this is due to the loss of communication from everything being literally turned off...


The fans starting from sleep mode happened twice after I encountered the issue originally. I've had the fans for over 6 months without issue of starting from sleep mode.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...