Jump to content
Corsair Community

Corsair M65 blinking LED and it doesn't work anymore


Recommended Posts

Hi at all

First of all I'm an italian student, so apologize me if I make some grammar mistakes


I've got a Corsair M65 Gaming Mouse since one month

Today I've turn on my pc and I notice that leds were blinking and the mouse is not working anymore, I've tried to do a firmware update but my PC isn't recognizing it.

I've tryied it on another computer but it has the same problem


Some M65's users had my same problem? I didn't found any help on Google...


[/ame] I've made a video...
Link to comment
Share on other sites

I haven't seen a thread mentioning the L.E.Ds .blinking.


As they still blink on another computer, the mouse might be faulty. Request an RMA to replc e it.


Thank you very much, I've bought it from Amazo and I'll ask for the warranty service ;)

Link to comment
Share on other sites

  • 2 years later...

Hello, I'm from Ecuador, so apologize me if I make some grammar mistakes


Please i need some help, i bought a vengeance m65 7 months ago, but a month ago it do not work anymore, when i started the pc the mouse start blinking like some others m65 user's, i tried in all usb ports and others computers but nothing. So i toke it to the store for warranty but they did not give me a solution. (the store just give 6 months warranty in mouses, which they recently told me)


Since i got a pc gaming one month ago, i start using the mouse for games, before that, i only used it for browsing and basic stuff.


I hope ther is a solution yet, thanks

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...