Jump to content
Corsair Community

Update problem


Recommended Posts

Corsair Force 3


Trying to update firmware from 1.3.3 to recent or at least lower. Signature 22788, Win 7 64. Tried field updater and Toolbox, all fail. Same problem in safe mode or Windows. Numerous searches comes up empty.


Any help is appreciated.

Link to comment
Share on other sites

MB: Asus 970A-G45

CPU: AMD Phenom II x4 975

Video: eVGa gtx 550 tI

Ram: 16GB

PS: OCZ 750W

SSD: Corsair Force 3 120GB

Second drive: Seagate Baracuda 1TB


AHCI is enabled (recently and showing as SCSI in device mangler)

SSD is plugged into SATA 2 on the MB (AMD SATA controller)


Hope this info helps.

Link to comment
Share on other sites



Firmware update worked.


Updated the drive for IDE ATAA/ATAPI controllers from AMD Sata controller to Standard AHCI1.0 Serial ATA controller, then downloaded 5.0.5, updated via field updater and it worked.


Used Toolbox to update to 5.0.7


Thanks again Toasted, I kept re-installing the driver for the disk drive not the controller

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...