Jump to content
Corsair Community

Voyager 16gb Mini USB Keychain Drive


Recommended Posts

Hello, recently purchased from Newegg.com


(2) Corsair USB 3.0 16gb Thumb Drives. I had opened one to use.


I have a Macbook Pro Late 2011 that I carry with me always. I went to put some downloads onto this new drive I opened and it is not detected by the Macbook at all. I shrugged it off and then plugged it into a Windows machine, Win 7 Pro x64 - worked fine. At work the next day I tried it on a Win XP 32 system and worked fine.


Will not work on my Macbook pro.


I read another forum post… the person who replied said to try SDFormatter, I downloaded that on a WinXP 32 system and ran it. It wouldn’t allow me to change the file system from FAT 32 to NTFS.


I did download a HP program for formatting USB thumb drives. I ran it, had it change the File system to NTFS, it correctly formatted the drive and windows saw it.


Put it in my macbook pro… and Nothing again. It’s not even detected as a device at all.


I do have an ADATA brand 8gb USB 3.0 Thumb Drive, that drive has worked flawlessly on every computer I ever plugged it into and perfect fine on my Macbook,


Macbook Pro Late 2011

OS X Mavericks (always fully updated)


I had also reset the SMC and PRAM prior to doing the testing today of the drive after doing different formatting.


Looking for any ideas / support / advice / assistance.


Only thing I do not have is a USB 3.0 drive that is 16gb from another brand / Manufacturer to try. Only size I had is an 8gb USB 3.0.


When I get home tonight from work I will try the 2nd drive to see if it does work. I meant to try it before and didn't.



Thanks for any and all help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...