Jump to content
Corsair Community

How to disable mic loopback? (1500)


Recommended Posts

  • 2 weeks later...

If you're referring to 'hearing yourself' through the headset while talking into your mic then it's almost the same for each OS.

These steps are for Windows 7:

Click Start -> Control Panel

- In the top right you should see "View by:", if it says "small or large icons" then find 'sound' in the list below.

- If it says "category" click on 'hardware and sound' and then 'sound'

Go to the recording tab.

Right click on your mic in the list and go to 'properties'

Go to the listen tab

Uncheck the box that says "listen to this device"

Click apply and you should disable the loopback at that point.


Hope that helps. Be it a week late!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...