Jump to content
Corsair Community

R6025 - pure virtual function call


Recommended Posts

Hi. I installed to 2.0.16 drivers and immediately stated getting the above MS C++ error when exiting Skyrim. I did some research and found all kinds of solutions like reinstalling the affected app (not an option due to many mods and being way deep in the game), to running a reg cleaner (which I did, but it didn't work), to a System Restore to a point before the issue started (which I also did).


The System restore thing did fix the problem... by removing the Corsair driver and restoring the Razer Synapse software I had previously installed (because the Corsair 2.0.06 drivers were just bad).


So now with problem completely fixed, I decided to uninstall the Razer software and try the Corsair 2.0.16 drivers again... and bang! Immediately ran into the R6025 errors again.


So I think it's pretty conclusive at this point... the problem here is the Corsair driver.


Has anyone else run into this? Do the Corsair driver devs know about it? Is there a fix?


If not, do they read here, or do I need to do something else to alert them to the problem?





Link to comment
Share on other sites

Do you have the latest DirectX and Visual C++ Redistributable?

Have you tried the Beta 2.0.19 drivers?




Yes (although the redistributables for this game are actually not the latest from MS... DX9, DX10 and C++ 2010).


I have not tried the 2.0.19 beta because it wasn't clear if this was just for Win8.1. I'm running Win7 x64.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...