Jump to content
Corsair Community

Corsair F3 90 gb,sata III ssd not compatible with Z87 chipset?...


Recommended Posts


I have an Corsair F3 90 gb sata III ssd with Windows 7 x64 Ultimate SP1 installed on it.

My mobo is Gigabyte Z87X-UD4H and cpu is I5 4670K.

I encountered some issues with the ssd on Intel sata port 0 - drive dissapear while i'm desktop,or browsing or play BF3 with friends,after that restart and mesage ''please insert the proper boot device...''.

I checked the bios and my ssd went to nowhere... I shutted down the PC and disconncet/reconect the sta cable in order to get back the drive and OS. It worked for another two days and happened again...

I flashed Bios two times,OS was installed in AHCI,sata enabled.

I cannot flash the ssd firmware since i have Windows on it (at least that's what i tought...).

Anyway there's some users that says that old SF controllers like SF 1200/1600 has detection problems with Z87 boards,others says that any SF ssd older than 2012 has this sort of issue (mine is 2281 from 2011).

I don't know what i'm gonna do right now,there are a lot of opinions that confusing me: if i buy another ssd with another controller that will adress my problem,or sell the damn board and get another brand?...

I'm afraid that any other brand will perform like mine UD4H as time as i mantain the same drive with SF 2281.

I am connected to MARVELL port 0 now and everything is stable - the detection problem occured only on Intel sata port 0.

Please HELP!!!:[pouts:

Link to comment
Share on other sites

The thing is ssd working 100% with the same sata cable on Marvell port 0,so i guess is not the cable fault... I tried different port and same result.

And no,i cannot update my ssd thru that utility... It just downloading new firmware files and after that an error ocures with ''update failed'' message.

So,what else can be?...

Link to comment
Share on other sites

Power cycle your system where it is completely off for 30 seconds and restart. Check your firmware version again. FYI, it's probably not going to update over the Marvell controller.


If you can't update it on your own system, do you have access to another computer to do the update with?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...