Jump to content
Corsair Community

Neutron GTX Firmware Update no RAID


Recommended Posts

Hi guys,


I recently updated the firmware on both my GTX Neutron 120GB SSD's from M306 to M311. After the upgrade I switched back to RAID in the bios and set up for RAID 0. Now i cannot get through the windows 7 install. It will get through the setup stage where it copies and installs windows but after the first re start the computer crashes at the windows load screen.

In AHCI mode the install works fine and previous to the upgrade it worked in RAID and ACHI i had no problems. Is there anyway to get back to M306 firmware, i have been looking but i cant find it and SSD toolbox doesn't have an option to go back to older firmware.


My System Specs are

Ga 990FX ud7



So far I have tried to re flash the M311 firmware, no change. I have also re flashed the motherboard bios too and that made no difference.

Link to comment
Share on other sites


Thanks for the response, after many attempts last night i got it sorted. I re flashed the motherboard bios for the second time and then the raid array worked. In a the space of about 4 hours i installed windows about 10 times after rebuilding the array and secure erasing the drives.

Drives work fine and raid 0 speeds are very good.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...