Jump to content
Corsair Community

stuck on windows 7 startup logo screen


Recommended Posts

Hey guys,

So after investing in a corsair force GT, I used dban on my mechanical drive and installed a fresh copy of windows 7 onto my new SSD. However, for some reason, my computer seems to hang at the "windows is starting" splash screen. I tried swapping GPUs, reinstalling win7, booting in safemode (doesnt let me), using the repair tool on the win7 CD, taking out my mechanical drive, swapping sata ports, changing boot priority, but nothing really seems to fix the problem. As of now, I feel as if my computer either starts up in 10-15 seconds (with like a 30% chance) or is perpetually stuck at the windows logo. ATM, I'm convinced that either the SSD or the mobo is causing the problem; my computer was completely fine before hand. A friend of mine mentioned some incompatibility with some MSI mobos and SSDs, and said he experienced the same exact thing years ago. (he gave up and now boots the OS off his mechanical lol) Has anyone else ran into this problem? I'm on the verge of trashing my msi mobo and going for an asus mobo.


PS: Another friend of mine has an asus mobo and my SSD booted fine off that (might have been a coincidence since i've only tried it twice)

Link to comment
Share on other sites

I don't know, i keep reading about how if your computer works you shouldn't update the bios? I'm clueless and unexperienced when it comes to the bios, so i usually just avoid touching it


Now you have a good reason to update the bios as your computer no longer works. ;):


Seriously though, an update to the bios on any motherboard of relatively recent vintage is a pretty easy and painless task. Give it a shot before purchasing a new one.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...