Jump to content
Corsair Community

M60 Bricked After Firmware Update


Recommended Posts

Short Version:

> hadn't updated firmware for a few months

> wanted to set up macro on new machine

> updated firmware on new machine before installing driver [see below]

> mouse bricked [computer doesn't even recognize it's plugged in]

> tried all three USB 2.0 ports

> attempted to follow all instructions in threads regarding a firmware update bricking an M60, but none applied as the PC didn't even recognise the mouse was plugged in

> deleted all mouse drivers in Device Manager [even edited registry to show unplugged devices following instructions here]

> mouse still bricked

> will bring mouse in to work tomorrow and plug into work PC to see if it's an issue specific to my laptop


System info..? I'm a bit of a noob so I'm not sure what you need... The laptop is an Asus UL30A, Windows 7 [64 bit I think, whatever that means compared to 32 bit...]


Long story:

I'd been using my M60 with my laptop for a a year or so without any drivers or anything other than the ones Windows installed automatically when I first plugged in the mouse. I mainly used my desktop for gaming so I'd installed Corsair's drivers and the firmware there.


After I moved to South Africa a couple of months ago, I didn't bring my desktop over in the first shipment of stuff, so I'd been using my laptop exclusively for gaming, but today for the first time I encountered a situation where I wanted to set up a macro for use in Terraria.


Following the instructions in the zip folder I updated the firmware of the mouse first. When it started the mouse went dead, but I figured that was normal and I vaguely remembered it doing that when I updated the firmware for the first time on my desktop. The firmware update finished, no error messages, but the mouse didn't come back to life.


I tried following all the instructions for a firmware update bricking the M60, but none of the ones I've found applied because my PC doesn't recognize that the mouse is plugged in.


I tried deleting the default drivers windows installs by following the instructions here but it didn't help. I've tried all the USB ports...


I'm stuck. If anybody knows what I should try next, any help would be greatly appreciated.


Cheers, Notso.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...