Jump to content
Corsair Community

Brand new Voyager - can't see files on iphone app/update firmaware or set password


Recommended Posts

Just bought a brand new Voyager Air 1Tb. Initially, I couldn't update firmware or see files - see below. I connected the drive to a laptop running XP and then added a file from that laptop, ejected, powered down and then it worked ok.


Now, if I reconnect it to the PC running Windows 8 where all my media files are, it hits the same problem when I disconnect (can't find any way to do this safely as it doesn't give me the eject option)


Any ideas on how to fix this would be much appreciated! I'm now trying to recreate what I did to get it to work in the first place after being connected to the laptop!






Initial problem:


I can transfer files via USB to the Air (and play them direct from the drive via USB) but they do not appear when I look for them in the folder "Voyager Air" on the iPhone or ipad app.


I have also tried to update the firmware and have put the update in the root directory but when I power it back on it doesn't recognise that the file is there so doesn't prompt to update.


I have tried to set a password but when I then try to connect to it via wifi it just says that the password is incorrect and I have to reset the device to remove the password issue.


The app says that the firmware is 1.2.2

The app version is Apple iOS v1.2.12

Help please!


P.S. I've also tried to submit a technical question via the Corsair website but it doesn't seem to want to accept one unless you put in a dummy product description! Not very impressed by Corsair products or support so far.....

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...